Yeah, unfortunately Ive tried most of those those things, though I didnt see that somewhere along the line the images switched to bluetoothd
doing "hcitool dev" only replies with "Devices:" and nothing else.

things like "hidd --search" also do nothing, which is what I would expect if there werent any devices.

Im going to try messing around with hciattach, though Im sure I cant do any better than what the image does in terms of setting it up.
From what I gather /dev/ttyS2 is responsible for the bluetooth device.

of all the connections on this device it seems unlikely that a simple UART connection would be the only thing that doesnt work.

Any help on the specifics of the bluetooth devices communication would help though.


 
Have you tried another image , other than the factory nand image ?

Try one of the newer images or build your own (making sure to include
bluez4 , bluez-utils , bluez4-dev).

Try after loging in as root

bluetoothd
or
hcid
depending on what image you have

then hcitool dev
and see if any devices are listed.

We still get time outs on initialization with some images.
But bluetooth is useable both with the onboard and usb devices.
We are using bluetooth with pybluez (same code works on pc linux ,
windows and gumstix angstrom)

We handle it in our init script by calling bluetoothd again  then
waiting ten seconds then calling bluetoothd yet again.
eg
/etc/init.d/countstart  (with a symbolic link in run level 5  rc5.d/   )

#start bluetooth daemon to make sure all bluetooth devices are recognised.
bluetoothd

#create device for ppp
#mknod /dev/ppp c 108 0

#connect using dodo 3G modem
#pppd call dodo1

#sleep for 30 seconds to give time for pppd to start and to connect to dodo
sleep 10

# RESTART bluetooth daemon in case it timed out before
bluetoothd

#start count program
#python /home/alxx/py/pachube.py &
python /home/alxx/py/count.py &

#sleep to let program start without interuption
sleep 10



--
UTS CRICOS Provider Code:  00099F
DISCLAIMER: This email message and any accompanying attachments may contain
confidential information.  If you are not the intended recipient, do not
read, use, disseminate, distribute or copy this message or attachments.  If
you have received this message in error, please notify the sender
immediately and delete this message. Any views expressed in this message
are those of the individual sender, except where the sender expressly, and
with authority, states them to be the views the University of Technology,
Sydney. Before opening any attachments, please check them for viruses and
defects.

------------------------------------------------------------------------------
Download Intel® Parallel Studio Eval
Try the new software tools for yourself. Speed compiling, find bugs
proactively, and fine-tune applications for parallel performance.
See why Intel Parallel Studio got high marks during beta.
http://p.sf.net/sfu/intel-sw-dev
_______________________________________________
gumstix-users mailing list
gumstix-users@lists.sourceforge.net
https://lists.sourceforge.net/lists/listinfo/gumstix-users