Hi guys,

Just an update to my problem, I some more online about using the ir_ serial port on /dev/ttyS2.  I don't have a waysmall, so I soldered some wires to the holes on the tweener board corresponding to the IRRXD and IR_TXD on the 60-pin hirose connector.  For ground, I couldn't really find any info on which one I should use, so I soldered a jumper off from pin 42 (GND).  Would this be the correct ground for serial communication?  Anyways, I plugged it all in, and set GPIO46/47 to be INs and OUTs, then set the flow control to off and tried cating /dev/ttyS2...no luck.  Tried running GPSD on that line, still no luck.  Ahhhhh.

Any suggestions?  (the gps is at least spitting out stuff to the serial line, I checked that)

Thanks,
Eric

On 3/31/06, Eric M <erohead@gmail.com> wrote:
Hi,

Quick question:  I managed to get wifi working, and can successfully ssh in and start a terminal session.  Would it be possible to now connect a GPS straight to ttyS0 through the null-serial cable?  I'm trying to do it, but I don't seem to be seeing anything when I cat the line, or run gpsd.  Do I have to change something to stop ttyS0 from being used as a serial terminal?  I've also tried playing with the wiring of the pins, in case the IN and OUT lines on the gumstix-serial cable are different.

Any thoughts? I also have a robostix, is it possible to hook it up to that? Or would that require writing code for the amtel to forward the port.

Anyways, thanks.

Eric