Am trying to get sound to play via an audiostix2 and basix 400. I've upgraded to trunk openembedded and uboot 1.2.

On boot, I see this:

ALSA: loading sound modules...
ASoC version 0.13.0
asoc: AC97 HiFi <-> pxa2xx-ac97 _reset: cold respxa2xx_ac97_read: read error (acpxa2xx_ac97_read: read error (ac97_reg=7e GSR=0x0)
AC'97 0 access is not valid [0xfsoc-audio: probe of soc-audio faALSA: Restoring /usr/sbin/alsactl: load_state:1329:
No soundcards found...

When I log in, lsmod says:
root@gumstix-custom-basix:~$ lsmod | grep snd
snd_pcm_oss            38976  0
snd_mixer_oss          14688  1 snd_pcm_oss
snd_soc_gumstix         1700  0
snd_soc_ac97            2624  1 snd_soc_gumstix
snd_ac97_codec        102796  1 snd_soc_ac97
snd_soc_pxa2xx_ac97     6180  2 snd_soc_gumstix,snd_soc_ac97
snd_soc_pxa2xx          4320  1 snd_soc_gumstix
snd_soc_core           26464  2 snd_soc_ac97,snd_soc_pxa2xx
snd_pcm                67141  4 snd_pcm_oss,snd_ac97_codec,snd_soc_pxa2xx,snd_soc_core
snd_timer              20516  1 snd_pcm
snd                    46548  6 sndcodec,snd_soc_core,snd_pcm,snd_timer
soundcore               6532  1 snd
snd_page_alloc          5832  1 snd_pcm
ac97_bus                1792  3 snd_ac97_codec,snd_soc_core,ucb1400_ts


Programs like mpg123 say no such card:
root@gumstix-custom-basix:/media/card$ mpg123 file.mp3
ALSA lib confmisc.c:769:(parse_card) cannot find card ''
ALSA lib conf.c:3510:(_snd_config_evaluate) function snd_func_card_driver returned error: No such device

Same with alsamixer:
alsamixer: function snd_ctl_open failed for default: No such device

There's a long thread here earlier this year with similar problems but they claim everything is resolved.
http://www.nabble.com/Re:-Gumstix-OE-AudioStix2-td14778423.html

Any ideas?