Thanks for the help, but still no luck. I have tried using bindings and opening a second file node like "rfcomm1", the incoming connection still gets routed to rfcomm0. I tried creating new channels and using host/ client code based on Bluez API to connect over those channels with no luck. eg.

    addr.rc_family = AF_BLUETOOTH;
        addr.rc_channel = (uint8_t) 2;
...

The two outgoing connections in that process somehow block any incoming on any channel. :(, my project demonstration is next tuesday.


On Thu, Mar 26, 2009 at 11:41 PM, Marc Humphreys <mhumphreys@logiclinkdesign.com> wrote:

You need to open up another rfcomm channel. Take a look at this FAQ, where a second serial connection is established over rfcomm1.

 

http://docwiki.gumstix.org/index.php/Frequently_asked_questions/Bluetooth#How_can_I_connect_to_a_Bluetooth_GPS_Receiver.3F

 

 

Marc

From: Peter Vandrish [mailto:peter.vandrish@gmail.com]
Sent: Thursday, March 26, 2009 7:55 PM
To: General mailing list for gumstix users.
Subject: [Gumstix-users] RFCOMM Help!

 

Hi,
I am trying to use a Basix to connect to a verdex over bluetooth, that works, and I can also connect to a sensor board over bluetooth. With those 2 connections established, the Basix can no longer receive an incoming connection to rfcomm0. Can anyone help me?
Thanks,
Pete


------------------------------------------------------------------------------

_______________________________________________
gumstix-users mailing list
gumstix-users@lists.sourceforge.net
https://lists.sourceforge.net/lists/listinfo/gumstix-users