hi,

so i've downloaded the latest svn today, rev1400...
compiled a new image including bplay and mpg123

then:

22:22 < a|ejo> modprobe snd-pcm-oss
22:22 < a|ejo> modprobe snd-mixer-oss
22:22 < a|ejo> modprobe snd-pxa2xx-ac97
22:22 < a|ejo> /dev/dsp is created
22:22 < a|ejo> so i think, cool! now i have it
22:23 < a|ejo> but when i try to use /dev/dsp -> # brec foo brec: /dev/dsp: Invalid argument

the device appears listed:

22:24 < a|ejo> # cat /proc/asound/UCB1400/id
22:24 < a|ejo> UCB1400
22:25 < a|ejo> UCB1400 is the card as far as i understand


I tried playing an 8 bit, Rate 8000 Hz, Mono file just in case the rates where the problem but still no go.

does this mean that i still have to patch the old revision?

why is not possible to have an image that includes at least one basic sound application to test the card (is a new card, as you can see it hasnt been used not even once since it arrived 2 months ago, but who knows maybe is a malfunctioning card?)

for real, im in disspair after this long time trying to get basic sound out of the gpstix.

any advice, anyone has a connex400-BT+gpstix with audio working that could share the root image?

thanks for any advice,

/a

:*