I am new to the Open Embedded toolchain. As mentioned in the User Wiki (gumstix.net -> "Build Environment on Ubuntu"), I built the kernel image and filesystem using "bitbake gumstix-basic-image" . I found the resulting kernel image and filesystem image in deep in the $GUMSTIX-OE/tmp directory.

I created the flash image with the correct u-boot, kernel and filesystem image and tried running it using Qemu.

qemu-system-arm -M verdex -pflash flash.img -monitor null -nographic -m 289

Uboot starts fine and starts booting the kernel. But then it gets aborted giving this message :

Configuring update-modules
qemu: fatal: smc91c111_read: Bad reg 0:30e

R00=d0870300 R01=00000300 R02=00000004 R03=d0871000
R04=cf8071ec R05=bf0609d8 R06=bf060a20 R07=cf80721c
R08=00000016 R09=00000016 R10=d0870000 R11=cfb97ef4
R12=00000000 R13=cfb97ed8 R14=c00359e4 R15=bf06204c
PSR=20000013 --C- A svc32

I googled this error and I found someone else who had the same problem. And it was said that it worked fine on FreeBsd and it could be a gcc (with which Qemu was compiled) version problem. I used GCC 4.1 and the latest Qemu source files. One solution suggested was to reconfigure the kernel disabling all networking devices. That didnt work either. It gave the same error. I also tried using the "-net none" option in the Qemu command. And on executing this i got a "Segmentation Fault". I was wondering if anyone else encountered with this problem in the past and how to get around this. Any help will be appreciated. Thank you so much.