I recently purchased the Gumstix Connex400, GPSStix, and RoboStix boards.  I connected the GPSStix to the Connex and tried to log in through USBnet -- after a number of tries, USBnet came up and I was able
 to log in.  However, the Gumstix locked up during the session and I was unable to reconnect through USB.

I borrowed a friend's Tweener board and tried to connect over serial; when I tried to log in over Hyperterminal (115200bps, no hardware flow control), all I got was garbage over the terminal (random non-ascii characters, etc). The same character stream would come when pressing the reset button. I also tried this under Minicom and Kermit in both Ubuntu (on the same computer) and Red Hat (in the lab) and got similar errors. Under Ubuntu, I got the same random character stream, and under
Red Hat, I would only get the random stream sporadically.

This Tweener works on my friend's Gumstix with no problem; my GPSstix has no issues with his board either.

Has anyone seen anything like this/how can I reconnect to the machine?

Thanks,
Karthik