Hello all,
I was wondering if anyone could help me on this one. To start with, I don't have a network connection on my gumstix. That said, I need to get gphoto2 on to my gumstix to snap a few pictures using a USB we camera. I tried including gphoto2 in the recipe for gumstix-basic-image (gumstix-basic-image.bb) and rebuilt everything. This appeared to work, I had gphoto2 on the gumstix. I could auto-detect and it would find my camera, get info, etc. The problem came when I tried to capture a preview using the --capture-preview switch. On my laptop and desktop this produces an image called sq_cap.ppm in the current working directory. But on the gumstix, I know it's taking a picture and transferring data to the gumstix (via the display on the camera) and the program reports that it saved it as sq_cap.ppm. However, this file is nowhere to be found on the gumstix. Does anyone know of either:

1. A way to get gphoto2 on the gumstix (probably via serial connection) without getting caught in dependency hell? (I encountered this my first time around couldn't bitbake a few libs or find a package that provides them)

2. I have a Linksys Etherfast 100M USB network adapter that uses the RTL8150 driver. Does anybody know how to enable this driver and build/install it onto the gumstix? (probably same install method as mentioned on gumstix.net?) The thought here was to just pikg install gphoto2 from the gumstix and have that work...

Thanks,
Mike