Well I fixed that problem. Made a symlink to where it was looking and it seemed to work:

# cd /usr/avr/lib/

then

# ln -s /usr/lib/binutils/avr/2.18/ldscripts .

(note the '.' at the end) This solved the previous error, but now I'm getting this:

(...)
Packaged contents of robostix-kernel-module into /home/Noonien/gumstix/gumstix-oe/tmp/deploy/glibc/ipk/gumstix-custom-verdex/robostix-kernel-module_1.0-r0_gumstix-custom-verdex.ipk
robostix-avr-ArgTest
*** Error: Package name  contains illegal characters, (other than [a-z0-9.+-])

ipkg-build: Please fix the above errors and try again.
NOTE: Task failed: ipkg-build execution failed
NOTE: package robostix-1.0-r0: task do_package_write_ipk: failed
ERROR: TaskFailed event exception, aborting
NOTE: package robostix-1.0: failed
ERROR: Build of /home/Noonien/gumstix/gumstix-oe/com.gumstix.collection/packages/robostix/robostix.bb do_package_write_ipk failed
ERROR: Task 12 (/home/Noonien/gumstix/gumstix-oe/com.gumstix.collection/packages/robostix/robostix.bb, do_package_write_ipk) failed
NOTE: Tasks Summary: Attempted 306 tasks of which 306 didn't need to be rerun and 1 failed.
ERROR: '/home/Noonien/gumstix/gumstix-oe/com.gumstix.collection/packages/robostix/robostix.bb' failed


Is there a better work around, or does everything need to be lowercase (haven't tried it yet)? I saw that someone had this error earlier this month, any solution found that works?

Mike