Hello all,
I'm probably doing things a bit out of order, but I'm trying to get my verdex to access the GPIO pins on a robostix though i2c-io. I'm at the latest version of OE and I've bitbaked the basic image with the proper lines un/commented in the config file for robostix to be included. Using uisp I've successfully loaded and ran the hex file for Flasher_LED from the old docwiki site. Man, those LED's are bright. But I couldn't figure out how to get i2c-io on the gumstix, except to bitbake robostix. After implementing the root:root fix in the recipe, all seemed to go well. But I've hit this, and I'm not sure how to fix it (I run Gentoo on my host machine and it's all worked up to this point):


NOTE: Running task 281 of 310 (ID: 7, /home/Noonien/gumstix/gumstix-oe/com.gumstix.collection/packages/robostix/robostix.bb, do_compile)
NOTE: package robostix-1.0: started
NOTE: package robostix-1.0-r0: task do_compile: started
ERROR: function do_compile failed
ERROR: log data follows (/home/Noonien/gumstix/gumstix-oe/tmp/work/gumstix-custom-verdex-angstrom-linux-gnueabi/robostix-1.0-r0/temp/log.do_compile.27275)
| Building ArgTest/ ...
| Linking ArgTest.elf ...
| /usr/libexec/gcc/avr/ld: cannot open linker script file ldscripts/avr5.x: No such file or directory
| make[1]: *** [ArgTest.elf] Error 1
| make: *** [ArgTest/] Error 2
NOTE: Task failed: /home/Noonien/gumstix/gumstix-oe/tmp/work/gumstix-custom-verdex-angstrom-linux-gnueabi/robostix-1.0-r0/temp/log.do_compile.27275
NOTE: package robostix-1.0-r0: task do_compile: failed
ERROR: TaskFailed event exception, aborting
NOTE: package robostix-1.0: failed
ERROR: Build of /home/Noonien/gumstix/gumstix-oe/com.gumstix.collection/packages/robostix/robostix.bb do_compile failed
ERROR: Task 7 (/home/Noonien/gumstix/gumstix-oe/com.gumstix.collection/packages/robostix/robostix.bb, do_compile) failed
NOTE: Tasks Summary: Attempted 280 tasks of which 280 didn't need to be rerun and 1 failed.
ERROR: '/home/Noonien/gumstix/gumstix-oe/com.gumstix.collection/packages/robostix/robostix.bb' failed


Any ideas? If I knew where it was trying to find avr5.x I'd make a link to it (it did get installed to /usr/lib/binutils/avr/2.18/ldscripts/ ).

Mike