I am trying to run Player on the Gumstix (Verdex + Robostix +
netwifimicroSD), which in turn is going to be connected to the iRobot
Create. I downloaded Player 2.1.1 and configured it as follows:

./configure --build=x86-linux --host=arm-angstrom-linux --disable-alldrivers
--enable-roomba --prefix=/gumstix-buildroot/
CFLAGS=-fPIC --with-pic

I built and installed Player based on this configuration. Once it was
installed, I transferred the executable to the Gumstix and tried to run it
as follows:

# ./player roomba.cfg

It gave me:

-sh: ./player: not found

I'm not sure why its doing this. Whats even more weird is that when I try to
open it up using vi, it gives me the following:

#! /bin/bash

# player - temporary wrapper script for .libs/player
# Generated by ltmain.sh - GNU libtool 1.5.26 Debian 1.5.26-1ubuntu1
(1.1220.2.493 2008/02/01 16:58:18)
# The player program cannot be directly executed until all the libtool
# libraries that it depends on are installed.
# This wrapper script should never be moved out of the build directory.
# If it is, it will not operate correctly.

# Sed substitution that helps us do robust quoting.  It backslashifies
# metacharacters that are still active within double-quoted strings.
Xsed='/bin/sed -e 1s/^X//'

# Be Bourne compatible (taken from Autoconf:_AS_BOURNE_COMPATIBLE).
if test -n "${ZSH_VERSION+set}" && (emulate sh) >/dev/null 2>&1; then
 emulate sh
 # Zsh 3.x and 4.x performs word splitting on ${1+"$@"}, which
 # is contrary to our usage.  Disable this feature.
 alias -g '${1+"$@"}'='"$@"'
 case `(set -o) 2>/dev/null` in *posix*) set -o posix;; esac
BIN_SH=xpg4; export BIN_SH # for Tru64
DUALCASE=1; export DUALCASE # for MKS sh

# The HP-UX ksh and POSIX shell print the target directory to stdout
# if CDPATH is set.
(unset CDPATH) >/dev/null 2>&1 && unset CDPATH

relink_command="(cd /home/adheer/player-2.1.1/server; { test -z
\"\${LIBRARY_PATH+set}\" || unset LIBRARY_PATH || { LIBRARY_PATH=; export

# This environment variable determines our operation mode.
if test "$libtool_install_magic" = "%%%MAGIC variable%%%"; then
 # install mode needs the following variable:
 notinst_deplibs=' ../server/libplayerdrivers/libplayerdrivers.la
../libplayercore/libplayercore.la ../libplayercore/libplayererror.la
 # When we are sourced in execute mode, $file and $echo are already set.
 if test "$libtool_execute_magic" != "%%%MAGIC variable%%%"; then
   # Make sure echo works.
   if test "X$1" = X--no-reexec; then
     # Discard the --no-reexec flag, and continue.
   elif test "X`($echo '\t') 2>/dev/null`" = 'X\t'; then
     # Yippee, $echo works!
 # Restart under the correct shell, and then maybe $echo will work.
     exec /bin/bash "$0" --no-reexec ${1+"$@"}

 # Find the directory that this script lives in.
 thisdir=`$echo "X$file" | $Xsed -e 's%/[^/]*$%%'`
 test "x$thisdir" = "x$file" && thisdir=.

 # Follow symbolic links until we get to the real thisdir.
 file=`ls -ld "$file" | /bin/sed -n 's/.*-> //p'`
 while test -n "$file"; do
   destdir=`$echo "X$file" | $Xsed -e 's%/[^/]*$%%'`

   # If there was a directory component, then change thisdir.
   if test "x$destdir" != "x$file"; then
     case "$destdir" in
     [\\/]* | [A-Za-z]:[\\/]*) thisdir="$destdir" ;;
     *) thisdir="$thisdir/$destdir" ;;

   file=`$echo "X$file" | $Xsed -e 's%^.*/%%'`
   file=`ls -ld "$thisdir/$file" | /bin/sed -n 's/.*-> //p'`

 # Try to get the absolute directory name.
 absdir=`cd "$thisdir" && pwd`
 test -n "$absdir" && thisdir="$absdir"


 if test ! -f "$progdir/$program" || \
    { file=`ls -1dt "$progdir/$program" "$progdir/../$program" 2>/dev/null
| /bin/sed 1q`; \
      test "X$file" != "X$progdir/$program"; }; then


   if test ! -d "$progdir"; then
     mkdir "$progdir"
 rm -f "$progdir/$file"

   # relink executable if necessary
   if test -n "$relink_command"; then
     if relink_command_output=`eval $relink_command 2>&1`; then :
       echo "$relink_command_output" >&2
       rm -f "$progdir/$file"
       exit 1

   mv -f "$progdir/$file" "$progdir/$program" 2>/dev/null ||
   { rm -f "$progdir/$program";
     mv -f "$progdir/$file" "$progdir/$program"; }
   rm -f "$progdir/$file"

 if test -f "$progdir/$program"; then
   if test "$libtool_execute_magic" != "%%%MAGIC variable%%%"; then
     # Run the actual program with our arguments.

     exec "$progdir/$program" ${1+"$@"}

     $echo "$0: cannot exec $program $*"
     exit 1
   # The program doesn't exist.
   $echo "$0: error: \`$progdir/$program' does not exist" 1>&2
   $echo "This script is just a wrapper for $program." 1>&2
   echo "See the libtool documentation for more information." 1>&2
   exit 1

I don't know what this means, I'm a newbie at this stuff. I also tried to
run the player on my desktop whose details are:

uname -a
Linux adheer-desktop 2.6.20-17-generic #2 SMP Mon Jun 9 19:21:17 UTC 2008
x86_64 GNU/Linux

I got,:

root@adheer-desktop:~/player-2.1.1/server# ./player
Player v.2.1.1
USAGE:  player [options] [<configfile>]

Where [options] can be:
 -h             : print this message.
 -d <level>     : debug message level (0 = none, 1 = default, 9 = all).
 -p <port>      : port where Player will listen. Default: 6665
 -q             : quiet mode: minimizes the console output on startup.
 <configfile>   : load the the indicated config file

The following 1 drivers were compiled into Player:


which is the way I expect it to behave on the Gumstix. Can someone help me
solve this problem, I have tried and tried only to fail. Could this be a
compiler issue, why isn't the darned thing running on the Gumstix. Please
let me know,