Thanks very much for your answer
(for all others: the original answer is appended at the bottom of my mail)

Unfortunately, the problem coundn't be solved. In your first line you tell me I should run "ifconfig -a". Well, and there I don't see lo0, eth0 and wlan0, but instead lo, wlan0 and wlan0:avahi. Here is the printout:

lo        Link encap:Local Loopback 
          inet addr:127.0.0.1  Mask:255.0.0.0
          inet6 addr: ::1/128 Scope:Host
          UP LOOPBACK RUNNING  MTU:16436  Metric:1
          RX packets:44 errors:0 dropped:0 overruns:0 frame:0
          TX packets:44 errors:0 dropped:0 overruns:0 carrier:0
          collisions:0 txqueuelen:0
          RX bytes:2848 (2.7 KiB)  TX bytes:2848 (2.7 KiB)

wlan0     Link encap:Ethernet  HWaddr 00:19:88:11:E4:2A 
          UP BROADCAST MULTICAST  MTU:1500  Metric:1
          RX packets:0 errors:0 dropped:0 overruns:0 frame:0
          TX packets:0 errors:0 dropped:0 overruns:0 carrier:0
          collisions:0 txqueuelen:1000
          RX bytes:0 (0.0 b)  TX bytes:0 (0.0 b)

wlan0:avahi Link encap:Ethernet  HWaddr 00:19:88:11:E4:2A 
          inet addr:169.254.6.191  Bcast:169.254.255.255  Mask:255.255.0.0
          UP BROADCAST MULTICAST  MTU:1500  Metric:1

To be honest, I'm totally confused. Why exist two WLAN networks? (I guess 1 is the real one, and 1 is the renamed ethernet... but then again, why do both claim to be encapped by ethernet?) and especially wlan0:avahi is disturbing. The adress I would like to use is 192.168.0.100, with subnetmask 255.255.255.0 (Broadcast 192.168.0.255) - but here everything is different. I worked with debian and ubuntu for 2 years now, and while not everything worked instantly, I never had a configuration so disturbing as this one... are there other configuration files that I could alter? From where do those addresses (169.254 etc.) come? There are no other networks around my computer or the gumstix could connect to.

But back to the Ethernet: Yes, DHCP would be nice (and required^^). Unfortunately I can edit the config file as much as I want - it looks like someone "pulled the plug" on the ethernet connection (tried different cables etc.). I guess this is because really no ethernet shows up in "ifconfig -a"? There must be some kind of standard How-To that simply takes the shipped image and makes it work. Locking you on your gumstix with neither internet over ethernet and WLAN makes updating really hard. Especially for those with no card readers.

As always, any help is appreciated. Even if you have a link to a tutorial or a How-To, I'll gladly take my chances.

Greetings
Florian Besser

> From: scottellis.developer@gmail.com
> To: f.besser@hotmail.com
> Subject: Ethernet + WiFi on Overo
> Date: Tue, 15 Dec 2009 06:39:46 -0800
>
> Run ifconfig -a
> You should see lo0, eth0 and wlan0
>
> If not, then you have to fix that first.
>
> Change the addresses I'm using to what you want.
>
> To manually configure eth0
> ifconfig eth0 192.168.1.2 netmask 255.255.255.0
>
> If you want it permanent, edit /etc/network/interfaces
>
> auto eth0
> iface eth0 inet static
> address 192.168.1.2
> netmask 255.255.255.0
> network 192.168.1.0
> gateway 192.168.1.1
>
> or if you want eth0 to be a dhcp client
>
> auto eth0
> iface eth0 inet dhcp
>
> There's lots of variations with wireless.
> Without a key, its pretty much the same as wired except you need
> to associate first.
>
> Manually it's something like
>
> iwconfig wlan0 mode managed essid <some_ssid> channel n
>
> then
>
> ifconfig wlan0 192.168.2.1 netmask 255.255.255.0
>
> etc...
>
>
> I'm doing this from memory, no gumstix handy, so there might be
> some typos in there.
> /etc/network/interfaces has examples.
>
> This is all standard Linux stuff, nothing gumstix specific.
>
> That's why you don't see many explanations on the gumstix lists.


http://www.timefight.de/




Samichlaus und Weihnachts Fotos: direkt im Messenger mit Freunden austauschen