I am VERY new to linux and have been working with the gumstix (as an isp for the robostix) now for about 1(1/2) months and have hit one road block after another. First I could not get a working buildroot environment even after I tried to build it on 4 different linux machines. I finally did get it to work in windows with VMware running Fedora Core. Next I ran into the problem of my robostix drivers, when inserted, threw out conflicting kernel version errors and would not let me force it into the kernel anyway. The buildroot  would not spit out a new root-fs-arm image so I didn’t know what to do, trying to keep moving forward I patched it with the module-init-tools to gain uisp support and it DID build the root-fs-arm image. I’m not sure why???. Now the robostix driver works but now my gumstix on board storage is 4mb and my file sys. Is 3.7mb, so simultaneously I hit 2 more walls #1 no space to drop my programs (I can put stuff in that last free space but then they will not delete!?!?). I have been trying to get the cf card expansion to work but it wont create hda in /dev and it is not present in fstab so I cant mount it, but when I remove the card from the slot it tells me that a PCMCIA card at socket 0 has been removed. #2 I cant get any code(even example code) to compile in the buildroot it gives me seemingly different errors every time. To solve this i'm trying to do it in WinAVR and use AVRLib but no luck yet…. If any one could help me with either of these 2 problems it would be awesome!!!!!!
            Aaron Jones