Hi Jason,
   You will have to 
On Aug 7, 2009, at 7:51 AM, Jason C. Mecham wrote:

I'm getting the following error when I attempt to do "bitbake linux-omap-2.6.29"

"No such file or directory: '/home/gumstix/oe/tmp/work/overo-angstrom-linux-gnueabi/linux-2.6.30-r40/install/omap-dss-doc'"

It looks like the wrong recipe is being built, i.e. linux-2.6.30.

Try creating a overo-oe/user.collection/recipes/linux folder

and copy the linux-omap-2.6.29 recipe and folder to the user.collection folder and run bitbake again.

If there are higher kernel version, you need to set DEFAULT_PREFERENCE = "-1" for the linux-omap-2.6.30 recipes, etc.

Also try setting the PREFERRED_PROVIDER_linux = "linux-omap" in your site.conf. I haven't tried this but you can explicitly specify which recipe will provide the linux kernel like this, plus I'm just joting this reply from memory, so you need to look at the openembedded user guide on setting PREFERRED_PROVIDER and PREFERRED_VERSION to figure this out. 

You would set PREFERRED_VERSION_linux_omap = "2.6.29"

The PREFERRED_PROVIDER_linux = "linux-omap" and PREFERRED_VERSION_linux_omap = "2.6.29", together will ensure that the linux-omap-2.6.29 recipe gets built. 

Let me know it it works.

Best regards,

Elvis