Hi,

I have a Caspa VL module, and tried running your script using the 3.0 kernel.  It appears to hang "Unable to start streaming: 22."  trying to capture some frames.

Is there something in the uboot environment that I need to set reserved memory?

Is the pipeline necessary if one just wants to capture a single un-altered frame?

Thanks,

Roger 

reset media-ctl
Resetting all links to inactive


media-ctl -l mt9v032 3-005c:Pad0->OMAP3 ISP CCDC:Pad0[Active1]
Setting up link 16:0 -> 5:0 [1]


media-ctl -l OMAP3 ISP CCDC:Pad2->OMAP3 ISP preview:Pad0[Active1]
Setting up link 5:2 -> 7:0 [1]


media-ctl -l OMAP3 ISP preview:Pad1->OMAP3 ISP resizer:Pad0[Active1]
Setting up link 7:1 -> 10:0 [1]


media-ctl -l OMAP3 ISP resizer:Pad1->OMAP3 ISP resizer
output:Pad0[Active1]
Setting up link 10:1 -> 12:0 [1]



Now proceed with Formatting the pipelines


media-ctl -f mt9v032 3-005c:0 [SGRBG10 752x480]
Setting up format SGRBG10 752x480 on pad mt9v032 3-005c/0
Format set: SGRBG10 752x480
Setting up format SGRBG10 752x480 on pad OMAP3 ISP CCDC/0
Format set: SGRBG10 752x480


media-ctl OMAP3 ISP CCDC:0 [SGRBG10 752x480]
Setting up format SGRBG10 752x480 on pad OMAP3 ISP CCDC/0
Format set: SGRBG10 752x480

media-ctl OMAP3 ISP CCDC:pad1 [SGRBG10 752x480]
Setting up format SGRBG10 752x480 on pad OMAP3 ISP CCDC/1
Format set: SGRBG10 752x480

media-ctl -f OMAP3 ISP preview:pad1 [SGRBG10 752x480]
Setting up format SGRBG10 752x480 on pad OMAP3 ISP preview/1
Format set: YUYV 2032x4088
Setting up format YUYV 2032x4088 on pad OMAP3 ISP resizer/0
Format set: YUYV 2032x4088


Lets resize the image just for fun...
media-ctl -f OMAP3 ISP resizer:1 [UYVY 640x480]
Setting up format UYVY 640x480 on pad OMAP3 ISP resizer/1
Format set: YUYV 640x1021


yavta capture 4 frames from video6
yavta --capture=4 -f YUYV -s 640x480 -F /dev/video6
Device /dev/video6 opened.
Device `OMAP3 ISP resizer output' on `media' is a video capture device.
Video format set: YUYV (56595559) 640x480 buffer size 614400
Video format: YUYV (56595559) 640x480 buffer size 614400
8 buffers requested.
length: 614400 offset: 0
Buffer 0 mapped at address 0x40296000.
length: 614400 offset: 614400
Buffer 1 mapped at address 0x40378000.
length: 614400 offset: 1228800
Buffer 2 mapped at address 0x40423000.
length: 614400 offset: 1843200
Buffer 3 mapped at address 0x4057e000.
length: 614400 offset: 2457600
Buffer 4 mapped at address 0x40668000.
length: 614400 offset: 3072000
Buffer 5 mapped at address 0x40780000.
length: 614400 offset: 3686400
Buffer 6 mapped at address 0x408cc000.
length: 614400 offset: 4300800
Buffer 7 mapped at address 0x409e9000.
Unable to start streaming: 22.

On Mon, Jan 9, 2012 at 9:03 PM, Nader Rahimizad <nader@rahimizad.com> wrote:
I read in the following link that if V4L2 lib was correct, then the line
before last for mplayer would have worked but since it is not correct, i had
to load v412convert.so in order to get mplayer working as it popped open a
window on the GNOME display (I'm hooked up on Tobi using HDMI) and displayed
the camera output in continuous mode. I hope this helps those who would like
to save a number of hours and avoid fiddling with the pipeline setup as i
had to for the past two weeks! Cheers Guys...

#!/bin/sh
#
# File:   caspa.sh
# Author: Nader
#
# Created on Jan 9, 2012, 7:15:53 PM
#
# media-ctl [options] device
# -d, --device dev      Media device name (default: /dev/media0)
# -e, --entity name     Print the device name associated with the given entity
# -f, --set-format      Comma-separated list of formats to setup
#     --get-format pad  Print the active format on a given pad
# -h, --help            Show verbose help and exit
# -i, --interactive     Modify links interactively
# -l, --links           Comma-separated list of links descriptors to setup
# -p, --print-topology  Print the device topology (implies -v)
#     --print-dot               Print the device topology as a dot graph (implies -v)
# -r, --reset           Reset all links to inactive
# -v, --verbose         Be verbose
#
# Links and formats are defined as
#       link            = pad, '->', pad, '[', flags, ']' ;
#       format          = pad, '[', fcc, ' ', size, [ ' ', crop ], [ ' ', '@',
frame interval ], ']' ;
#       pad             = entity, ':', pad number ;
#       entity          = entity number | ( '"', entity name, '"' ) ;
#       size            = width, 'x', height ;
#       crop            = '(', left, ',', top, ')', '/', size ;
#       frame interval  = numerator, '/', denominator ;
# where the fields are
#       entity number   Entity numeric identifier
#       entity name     Entity name (string)
#       pad number      Pad numeric identifier
#       flags           Link flags (0: inactive, 1: active)
#       fcc             Format FourCC
#       width           Image width in pixels
#       height          Image height in pixels
#       numerator       Frame interval numerator
#       denominator     Frame interval denominator
#
# To manipulate the Media controller device node, you can use Laurent’s
“media-ctl” command line tool, found here: [4]
#
# Sample commands for OMAP4430 Blaze board:
#
# To print topology in shell:
# ./media-ctl -d /dev/media0
#
# To reset all links, and link CSI2A mem output pad to respective v4l2
capture device node:
# ./media-ctl -d /dev/media0 -r -l '"OMAP4 ISS CSI2a":1 -> "OMAP4 ISS CSI2a
output":0 [1]'
#
# To set format on “ov5650 3-0036” sensor output and “OMAP4 ISS CSI2a” input
pads:
#./media-ctl -d /dev/media0 -f '"ov5650 3-0036":0 [SGRBG10
2592x1944]','"OMAP4 ISS CSI2a":0 [SGRBG10 2592x1944]'
#
# ./media-ctl -l '"mt9v032 3-005c":pad0->"OMAP3 ISP CCDC":pad0[active1]'
# ./media-ctl -l '"OMAP3 ISP CCDC":pad2->"OMAP3 ISP preview":pad0[active1]'
# ./media-ctl -l '"OMAP3 ISP preview":pad1->"OMAP3 ISP
resizer":pad0[active1]'
# ./media-ctl -l '"OMAP3 ISP resizer":pad1->"OMAP3 ISP resizer
output":pad0[active1]'

# ./media-ctl -f '"mt9v032 3-005c":pad0[SGRBG10 752x480]'
#
# ./media-ctl -f  '"OMAP3 ISP CCDC":pad0 [SGRBG10 752x480]'
# ./media-ctl -f  '"OMAP3 ISP CCDC":pad1 [SGRBG10 752x480]'
#
# ./media-ctl -f  '"OMAP3 ISP preview":pad0 [SGRBG10 752x479]'
#
# ./media-ctl -f  '"OMAP3 ISP resizer":pad0 [YUYV 734x471]'
# ./media-ctl -f  '"OMAP3 ISP resizer":pad1 [YUYV 640x480]'


#------------------------------------------------------
clear
echo ''
echo ''
echo ''
echo 'reset media-ctl'
media-ctl -r


#---- Link the pipelines --------------------------------------------------
echo ''
echo ''
echo 'media-ctl -l mt9v032 3-005c:Pad0->OMAP3 ISP CCDC:Pad0[Active1]'
media-ctl -l '"mt9v032 3-005c":0->"OMAP3 ISP CCDC":0[1]'

echo ''
echo ''
echo 'media-ctl -l OMAP3 ISP CCDC:Pad2->OMAP3 ISP preview:Pad0[Active1]'
media-ctl -l '"OMAP3 ISP CCDC":2->"OMAP3 ISP preview":0[1]'

echo ''
echo ''
echo 'media-ctl -l OMAP3 ISP preview:Pad1->OMAP3 ISP resizer:Pad0[Active1]'
media-ctl -l '"OMAP3 ISP preview":1->"OMAP3 ISP resizer":0[1]'

echo ''
echo ''
echo 'media-ctl -l OMAP3 ISP resizer:Pad1->OMAP3 ISP resizer
output:Pad0[Active1]'
media-ctl -l '"OMAP3 ISP resizer":1->"OMAP3 ISP resizer output":0[1]'


#------------------------------------------------------
#echo ''
#echo '-f OMAP3 ISP CCP2:1 [SGRBG10 752x480]'
#media-ctl -f '"OMAP3 ISP CCP2":1 [SGRBG10 752x480]'

#echo ''
#echo '-f OMAP3 ISP CCDC:2 [SGRBG10 752x480]'
#media-ctl -f '"OMAP3 ISP CCDC":2 [SGRBG10 752x480]'


#----- Format the pipelines
-------------------------------------------------
echo ''
echo ''
echo ''
echo 'Now proceed with Formatting the pipelines'

# media-ctl -f 'mt9v032:0[SGRBG10 752x480 (3,11)/752x480]
# OMAP3 ISP CCDC:2[SGRBG10 752x480],
# OMAP3 ISP preview:1[YUYV 752x480],
# OMAP3 ISP resizer:1[YUYV 752x480]'
#Setting up crop rectangle (3,11)/752x480 on pad mt9v032 3-005c/0

#------------------------------------------------------
echo ''
echo ''
echo 'media-ctl -f mt9v032 3-005c:0 [SGRBG10 752x480]'
media-ctl -f '"mt9v032 3-005c":0 [SGRBG10 752x480]'

echo ''
echo ''
echo 'media-ctl OMAP3 ISP CCDC:0 [SGRBG10 752x480]'
media-ctl -f  '"OMAP3 ISP CCDC":0 [SGRBG10 752x480]'


#------------------------------------------------------
echo ''
echo 'media-ctl OMAP3 ISP CCDC:pad1 [SGRBG10 752x480]'
media-ctl -f  '"OMAP3 ISP CCDC":1 [SGRBG10 752x480]'


#------------------------------------------------------
#echo ''
#echo 'media-ctl OMAP3 ISP CCDC:pad2 [SGRBG10 752x480]'
#media-ctl -f  '"OMAP3 ISP CCDC":2 [SGRBG10 752x480]'


#------------------------------------------------------
#echo ''
#echo 'media-ctl -f OMAP3 ISP preview:pad0 [SGRBG10 752x479]'
#media-ctl -f '"OMAP3 ISP preview":0 [SGRBG10 752x479]'


#------------------------------------------------------
echo ''
echo 'media-ctl -f OMAP3 ISP preview:pad1 [SGRBG10 752x480]'
media-ctl -f '"OMAP3 ISP preview":1 [SGRBG10 752x480]'


#------------------------------------------------------
#echo ''
#echo 'media-ctl -f OMAP3 ISP resizer:pad0 [UYVY 734x471]'
#media-ctl -f '"OMAP3 ISP resizer":0 [UYVY 734x471]'


#------------------------------------------------------
echo ''
echo ''
echo 'Lets resize the image just for fun...'
echo 'media-ctl -f OMAP3 ISP resizer:1 [UYVY 640x480]'
media-ctl -f '"OMAP3 ISP resizer":1 [UYVY 640x480]'


#------------------------------------------------------
echo ''
echo ''
echo 'yavta capture 4 frames from video6'
echo 'yavta --capture=4 -f YUYV -s 640x480 -F /dev/video6'
yavta --capture=4 -f YUYV -s 640x480 --skip 10 -F /dev/video6
--file=./capt.yuyv

#------------------------------------------------------
echo ''
echo ''
ls -lsha

#------------------------------------------------------
echo ''
echo 'wont work unless if we load libv41 first as u see in the next line'
#mplayer -tv
driver=v4l2:width=640:height=480:outfmt=uyvy:fps=25:device=/dev/video6 -vo
xv tv://

#------------------------------------------------------
echo ''
echo ''
LD_PRELOAD=/usr/lib/libv4l/v4l2convert.so mplayer tv:// -tv
driver=v4l2:device=/dev/video6




--
View this message in context: http://gumstix.8.n6.nabble.com/Mr-Sakoman-this-BUD-s-for-you-I-got-your-V3-2-R13-image-to-show-up-on-the-GNOME-desktop-tp3523330p3523330.html
Sent from the Gumstix mailing list archive at Nabble.com.

------------------------------------------------------------------------------
Write once. Port to many.
Get the SDK and tools to simplify cross-platform app development. Create
new or port existing apps to sell to consumers worldwide. Explore the
Intel AppUpSM program developer opportunity. appdeveloper.intel.com/join
http://p.sf.net/sfu/intel-appdev
_______________________________________________
gumstix-users mailing list
gumstix-users@lists.sourceforge.net
https://lists.sourceforge.net/lists/listinfo/gumstix-users