Did you ever actually flash the overo? Booting from the card does not flash it, it's only a temporary boot unless you did other measures to permanently flash the software into the overo.

Without the SD card plugged in, does it boot correctly?

Blaine


On Tue, Jan 10, 2012 at 6:30 AM, Adam Read <w0038651@umail.usq.edu.au> wrote:
Good evening all,

Well, I've been beating my head against this wall for a while now, and
concede that it now hurts quite a lot. Before we go any further, I'm a
complete muppet/newbie when it comes to Linux and Overo, and I'm trying
to learn Linux in a hurry so no doubt I'll come unstuck. That aside,
however.....

I purchased an Overo Water and Tobi board about a month ago, but hadn't
done all that much to it, beyond connecting to it via the USB console
port, and trying to get a bootable micro SDCARD working (it still
doesn't). I had not attempted to connect it to a monitor until
yesterday, as I was just checking to see what the console looked like.
The monitor remains blank even though the Overo has power applied to it,
so I don't know if this is a new thing from my playing or not.

I have tried, multiple times, to build the bootable SDcard from the
sakoman website, but it hasn't worked yet. Having downloaded the 429Mb
(roughly) file some dozen times, I must admit I'm getting pretty weary
of it all, and I don't have the knowledge or experience to tell it to
use previously downloaded copies.

Anyways, I now have two problems, and I'm really hoping someone can
point me in the right direction.

First, the Overo gives me an error over the console when it reaches the
overo login part - "JFFS2 notice: (965) check_node_data: wrong data CRC
in data node at 0x19a7e4c4: read 0x9ae87ba3, calculated 0x72b03a51."
This is a new development on the board, and has only been occuring the
last hour or so. As far as I know, the bootable sdcard hasn't actually
been working correctly, could this have hosed the overo?

Second, I keep getting an "improper  partitioning on /dev/mmcblk0"
message when I try to run Steve Sakoman's mksdcard.sh script. I'm
guessing I need a new sdcard, that or I've done something wrong.

Any help would be appreciated, and if anyone needs further information
then please let me know what commands to plug into the console (remember
that I have absolutely no idea).

Cheers,
Adam.



------------------------------------------------------------------------------
Write once. Port to many.
Get the SDK and tools to simplify cross-platform app development. Create
new or port existing apps to sell to consumers worldwide. Explore the
Intel AppUpSM program developer opportunity. appdeveloper.intel.com/join
http://p.sf.net/sfu/intel-appdev
_______________________________________________
gumstix-users mailing list
gumstix-users@lists.sourceforge.net
https://lists.sourceforge.net/lists/listinfo/gumstix-users