Hi Ben,

I tried the following statements with the output as follows:

root@overo:~# ifconfig -all
ifconfig: -all: error fetching interface information: Device not found
root@overo:~# sudo ifconfig eth1 up
-sh: sudo: not found                                                           
root@overo:~# sudo dhclient eth1                                               
-sh: sudo: not found                                                           
root@overo:~# ifconfig eth1 up                                                 
ifconfig: SIOCGIFFLAGS: No such device                                         
root@overo:~# dhclient eth1                                                    
ifconfig: SIOCSIFADDR: No such device

Does this mean that the eth1 is not detected. Does it have to be initialized somewhere?


On Mon, Oct 3, 2011 at 5:21 PM, Ben Harrison <signup@loquerion.com> wrote:



Can you try typing:


“ifconfig –all” – and see if eth1 appears in that list?


If it does, try:


“sudo ifconfig eth1 up”

“sudo dhclient eth1”


...If that works, you can make the change permanent by editing /proc/network/interfaces (google for syntax or copy what’s there).




From: Chinab Chugh [mailto:chinab91@gmail.com]
Sent: 03 October 2011 15:28
To: General mailing list for gumstix users.
Subject: [Gumstix-users] eth1 not working in Gumstix


Hi All,


I have tried to design an expansion board which is exactly similar to the Tobi-Duo in its schematics (and also has 2 ethernet ports).


I built a very simple kernel image comprised of from an online builder (http://narcissus.angstrom-distribution.org/). 


During run-time, when I try 'ifconfig -a', I am shown two connections - 'eth0' (this one works completely fine) and 'lo' (Link encap: Local Loopback .......). Although I expect eth1 to appear, it does not. 


I am pretty sure that the hardware of the expansion board is fine because I noticed that if I use an online standard kernel image downloaded from http://cumulus.gumstix.org/images/angstrom/factory/, both eth0 and eth1 do work! However, I would rather not use such a bulky kernel for a simple task of mine.


Why is the eth1 not initialized/ready? I would appreciate any suggestions to help me solve this issue.


Thanks! Have a cheerful day :)



All the data continuously generated in your IT infrastructure contains a
definitive record of customers, application performance, security
threats, fraudulent activity and more. Splunk takes this data and makes
sense of it. Business sense. IT sense. Common sense.
gumstix-users mailing list

Take care and enjoy the day!

Chinab :) :D :P