the default Amstrong image seem to work ok. It's only when I use the SD card with my Yocto gumstix-console-image or kernel (sakoman 3.5.0) that it's wrong?

2013/5/8 Katu Txakur <>

We are using Overo gumstix with a Tobi board for a big project. For some reason, the console doesn't always work and when it does, it stops working after a while. Specially when you type fast. It stops responding to the keyboard and I have to reboot the overo. I can always stop the boot sequence, but I cannot always type in the Overo# console once the boot is stopped.
When it boots normally, I can only sometimes login (as root). When everything goes fine, it will work for a while and then stops working, specially if I type fast or use the up arrow for previous commands.
 I've tried the following things but the problem persists and is quite frustrating as it seem to be ramdom. 

- I'm using a normal mini USB A to USB B cable. My computer has USB 2.0 (win 7) and I've tried different ports and two cables.
- I've tried using Putty (win 7), Minicom and Kermit (in a virtualbox with ubuntu 12.04). They all work sometimes and then get stuck. The settings for minicom are:
Serial Device: /dev/ttyUSB0
Bps/Par/Bits: 115200 8N1
Hardware Flow Control: No
Software Flow Control: No
(similar settings in Putty and Kermit)

- I've tried 4 different Tobi boards (all brand new) in 3 different computers. Some of them with LEDs and Switches in the 40 pint header and others without anything. In the ones with LEDs the problem happens more. I read somewhere that it could be electrical noise interpreted as input by the console, but it happens in the new ones too.
-I've tried the default Amstrong image and also different built images (with Yocto), different kernels and u-boots. None of them worked perfectly.

I guess that I'm either using the wrong cable for the console or wrong settings? 
Anyone with the same problem? any solution? 

Thanks in Advance for your help!