problem solved! The reason why my graphical helloWorld was not working is that I was typing 'jamvm Hello.class' instead of simply 'jamvm Hello'.
I am still having trouble getting jamvm to find the jpcap libararies though. This application was compiled using Netbeans 7.1 and the dist folder contains the jar file and a folder containing jpcap.jar and swingLayout.jar.
I am getting this error:
root@overo:jamvm -jar GUIFormExamples.jar
Exception during event dispatch:
java.lang.UnsatisfiedLinkError: Native libarary 'jpcap' not found (as file '') in gnu.classpath.boot.library.path and java.library.path

Where should I put the jpcap.jar file in order to make java find these files? I am sorry it's a very basic question but I don't know the answer to this.

On Wed, Mar 14, 2012 at 9:09 AM, R F <> wrote:
Just in case it helps in diagnosing the problem, here's the output from jikes when I try to compile the graphical HelloWorld application:
root@overo:/# export BOOTCLASSPATH=/usr/share/jamvm/
root@overo:/# echo $BOOTCLASSPATH
root@overo:/# export DISPLAY=:0.0
root@overo:/# jikes
Found 3 semantic errors compiling "":
     7.          final JLabel label = new JLabel("hello from Gumstix");
*** Semantic Error: Type "JLabel" was not found.

     7.          final JLabel label = new JLabel("hello from Gumstix");
*** Semantic Error: Type "JLabel" was not found.

     8.          frame.getContentPane().add(label);
*** Semantic Error: Ambiguous invocation of method "add". At least two methods a
re accessible from here: "void add(java.awt.PopupMenu $1);" declared in type "ja
va.awt.Component" and "java.awt.Component add(java.awt.Component $1);" declared
in type "java.awt.Container".

On Wed, Mar 14, 2012 at 12:08 AM, R F <> wrote:
Hi Everyone
I am trying to compile a java application on my gumstix overo. I've been following this guide ( and have had help from this forum. Here's the current state of affairs: I have installed jamvm (as part of which classpath-common and classpath-nominal were also installed), jikes and classpath-gkt. The installation classpath-dev failed because it tried to install libgcc which was already present. I've compiled a helloWorld app and it seems to run fine with jamvm. My linux version is 2.6.34 (Oct 2010).
Now I need to run another application which contains Java swing components as well as packet capture functionality (using JpcapCaptor). I've checked that this application compiles on a windows pc using NetBeans + jdk1.5. However, the compilation failes on gumstix and jikes spits out a large number of errors. I wasn't sure about the cause so I then tried to compile a simple graphical HelloWorld application ( which also uses Swing components. This application didn't compile either. Does that mean Jikes doesn't support swing (and perhaps awt)?  Or is it all due to the problems I had with classpath-dev?
Any help/suggestions/pointers would be really appreciated.