From the jpcap installation instructions  (http://netresearch.ics.uci.edu/kfujii/Jpcap/doc/install.html), I understand that I need JRE 6 in order for jpcap to work on my Gumstix board. (Is that correct?)
 
When I tried downloading openjdk-6-java uisng opkg, it gave me the following error:
 
Downloading http://www.angstrom-distribution.org.........
Collected errors:
* satisfy_dependencies_for: Cannot satisfy the following dependencies for openjdk-6-jre:
*        librhino-java *
* opkg_install_cmd: Cannot install package openjdk-6-java
 
 I can't find any info about librhino. Could anyone help me with this, please? I am using Gumstix overo with linux angstrom distro version 2.6.34. I also have JamVM version 1.5.3 on my board. I am able to run simple ?HelloWorld java applications, but nothing involving jpcap.
 
PS: Here's a bit of background: I am trying to download openJDK ONLY because my compiled jpcap file (libjpcap.so) doesn't seem to be visible to any java application that I try to run on gumstix. Not even when I copy it into the same folder (to rule out any path issues). Note that my libpcap is working fine (I used it with a C-language packet sniffer and it worked). If you think I don't need openjdk for jpcap to work then let me know, because that would make my main question irrelevant.