Hi All.

I would like to get Flash working with Firefox (or similar browser) on my Overo Earth. Basically, go to a website like Youtube (that uses Flash) and render video (or at least) audio content.   Is this possible?

I had not used my Overo in a while, so I pulled down the latest image from:
(http://www.sakoman.com/category/8-gnome-daily-builds-r13.html)
and put it on an SD card and let run through initial boot on the Overo.

Afterwards, to test, I went to youtube and tried to play a video.
First, I tried Epiphany and got the blue lego with question mark that has become synonymous with missing Flash on a mobile device.
Next, I tried Firefox, and it seemed to work a bit better.  Firefox provided a large, gray circle/play button on a black background that eventually gives way to a black background and a message below the window stating 'waiting on s.ytimg.com', or 'read i1.ytimg.com'.  Even after 30 minutes of waiting, this never seems to get anywhere.

Going into the firefox address bar, I can type about:plugins and it says (amongst) other things that Shockwave Flash 9.0 r999 is installed.

I wondered if perhaps the flash or Firefox version (3.6.8) needed an upgrade, but going into opkg, it seems that I have the latest versions supported by opkg.
I spent some time trying to download new versions of Firefox for Linux or Adobe Flash player for Linux, but then realized that those were built for x86 architectures, so that was not helpful.

Thoughts/suggestions on how to get Firefox+Flash working?

Thanks!
-Nate