I've run up against a problem here and have tried everything I can think of, but I can't manage to make my overo boot from onboard flash/nand and I'm hoping someone can't point out what I'm missing.

I have built a stock image from the yocto tree following the basic procedure outlined here and all the build steps completed successfully:

    https://github.com/gumstix/Gumstix-YoctoProject-Repo

I am able to create a bootable microsd card following the basic procedure outlined here:

    http://gumstix.org/software-development/how-to/198-create-a-bootable-microsd-card.html

I am able to boot from the microsd built with the kernel, rootfs, u-boot, and MLO out of my build/tmp/deploy/images/overo/ directory.  So far everything seems good, except ...

Now I want to write my new (working) images to flash/nand and boot without the microsd card.

I followed the basic procedure outlined here:

    http://gumstix.org/how-to/70-writing-images-to-flash.html

But I get an immediate error with u-boot and it doesn't properly load/run.  I then hunted around and found an alternate set of instructions to write u-boot to nand:

    http://www.sakoman.com/articles/12-how-to-write-u-boot-to-nand

After this u-boot is happy.  However when u-boot tries to load the kernel it spews a bunch of "Error: Bad compare! failed" messages and eventually gives up.  The Sakoman site also has similar instructions for installing the kernel, so I tried following those alternate instructions, but with no good result.

Does anyone have any idea what I'm missing here?  I'm not a complete novice and have successfully reflashed nand images last fall, but it seems like quite a bit has changed in the yocto tree and what I did before isn't working now.

This is an earlier overo, does that make a difference?  But it is booting fine with all the latest stuff as long as I boot from a microsd card. I just can't fine the magic to make this work in order to boot directly from flash/nand.

Thanks!

Curt.
--
Curtis Olson:
http://www.atiak.com - http://aem.umn.edu/~uav/
http://www.flightgear.org - http://gallinazo.flightgear.org