One thing I will often do is plug the device into a full blown linux desktop (such as Fedora 19 loaded on a PC) and see if that detects the device and then I can observe which modules it loads. After plugging in the device I run the dmesg command to dump out the recent kernel messages to my console.

This may not ultimately help you get things running, but it may show you how big of a gap you need to bridge to get to the solution.

Many devices don't have support in older kernels.  I bought a usb/ethernet dongle that was well supported in the 3.9.x kernels, but unfortunately was not supported in the 3.5.x kernel (3.5.x had support for a slightly older version with a slightly different usb product id. ... and I didn't get lucky by playing tricks in the code with product id.)

I also discovered that some things that were built as modules on my fedora system were built directly into the kernel on the gumstix system ... so the lack of a module for your device in /lib/modules/ doesn't necessarily mean the device is not supported.  But in my case the reason the driver was not activated was because my device was newer with an unsupported product id...

My sad story continued on with my purchasing a different dongle that the 3.5.x kernel did support (a TU2-ET100).  But my problems didn't end there ... I needed to connect the device through a powered hub via the USB OTG port and that worked up until the point where I tried to actually send traffic over and started getting timeout errors in some core USB modules.  It did work fine on a tobi board plugged into the USB Host port, but the tobi already has ethernet so I don't need the dongle there ... anyway, for now I've been shuffling files and data via a flash drive ... sub optimal, but better than ripping my system apart to get at the mmc card or to move the overo to a different carrier board to update it.



On Wed, Aug 21, 2013 at 2:18 PM, will2km <> wrote:
Good day!

I am working on a project and really in need of some advice. What I need to
do is to to use a usb wifi dongle to connect with a verdex board. I have a
customized extension board for usb connection and it's fully functional.
However, verdex doesn't recognize the dongle with factory image/kernel.

I think it's due to some missing modules but not sure what are they as I am
fairly new to verdex and OE in general. BTW the dongle I am using is from
alfa awus036h.

Please advise and thanks in advance.



View this message in context:
Sent from the Gumstix mailing list archive at

Introducing Performance Central, a new site from SourceForge and
AppDynamics. Performance Central is your source for news, insights,
analysis and resources for efficient Application Performance Management.
Visit us today!
gumstix-users mailing list

Curtis Olson: - -