On Mon, Dec 19, 2011 at 5:31 PM, FatalError <jim@macrousa.com> wrote:
UPDATE:
Two new Vbox machine images made, one Ubuntu 32-bit and the other Ubuntu
64-bit.
Used the "Using the Open Embedded Build System for Overo Series" setup on
each taken straight from the Gumstix website at
http://gumstix.org/software-development/open-embedded/61-using-the-open-embedded-build-system.html

Everything worked per the setup instructions except I had to install g++ per
a missing essential packages message error.

Build Configuration:
BB_VERSION        = "1.12.0"
METADATA_BRANCH   = "overo-2011.03"
METADATA_REVISION = "d042ac9"
TARGET_ARCH       = "arm"
TARGET_OS         = "linux-gnueabi"
MACHINE           = "overo"
DISTRO            = "angstrom"
DISTRO_VERSION    = "2011.03"
TARGET_FPU        = "hard"

After which each Vbox generates a penssl and openssl error.
NOTE: package openssl-native-1.0.0d-r14.0: task do_compile: Failed
ERROR: Function 'do_compile' failed (see
/home/jhobbs/oe/tmp/work/x86_64-linux/openssl-native-1.0.0d-r14.0/temp/log.do_compile.2726
for further information)
ERROR: Task 565
(/home/jhobbs/oe/oe-dev/recipes/openssl/openssl-native_1.0.0d.bb,
do_compile) failed with exit code '1'
ERROR: '/home/jhobbs/oe/oe-dev/recipes/openssl/openssl-native_1.0.0d.bb'
failed

Can you check the contents of the file referenced in the build failure above and if it has any worthwhile info post it back to the list?


Anyone have any idea's on how to get these things working?
Are these just useless instructions on the gumstix web page?
Anyone have a set of working instructions?

The instructions at gumstix.org work fine for me. It seems that most of the time when folks have issues its due to either using some build distro that isn't directly supported or they aren't reading the directions thoroughly. You'll find a lot of folks providing instructions/how-tos for gumstix, but if you try to use to many resources chances are good that you'll have problems. I'd suggest starting with the instructions at gumstix.org without considering any other resources, and see where that gets you. 
 

As a bonus I tried these additional instructions because I just want to see
something  work.
Ran GtkTerm, connected to the gumstix just fine.

http://www.gumstix.org/add-software-packages.html
Per the Opkg Package Management, First step:
$ opkg install helloworld-0.0.ipk

Got Collected errors:
 * wfopen: helloworld-0.0.ipk: No such file...

Actually, the first step on that page is to copy the helloworld ipk file to the gumstix. The sentence before that one tells you "lets imagine...", so its kind of letting you know its just an example. Since there is no helloworld ipk I don't see how you could be confused here... That is, if you read the page.
 

Do any of the instruction for use provided by Gumstix actually work?
These are some pretty basic instructions. Whats wrong here?
Can someone point out to me where some good instructions are.

Many of them work. Not all, but many. Just be sure to read things carefully.
 

All I want to do is write come simple code and have it run on the gumstix.
HOW DO I DO THIS?

Start with getting your build environment setup and building successfully. There are also other options like compiling code natively on the gumstix, but IMO for real development you'll want a proper build environment.

HTH,
Chris