Hello,

I have some trouble with the wifi of my overo airstorm. I have an access point providing an open connection with an essid (VERDEX)... I am able to connect to this access point with my gumstix verdex pro XL6P without trouble. I have on my verdex the following configuration in "/etc/network/interfaces"

     allow-hotplug wlan0
     auto wlan0
     iface wlan0 inet static
        wireless_mode managed
        wireless-essid VERDEX
     address 139.124.74.102
     netmask 255.255.255.0
     gateway 139.124.74.110

So i have configured my overo with the same but it doesn't work (I tried to use wlan0 or wlan1 in "/etc/network/interfaces" but it doesn't work for both of them, even if i reboot the gumstix):
 First it seems that wlan0 doesn't work because when overo has boot I obtained: 

overo login: UBI: scrubbed PEB 1419 (LEB 0:1417), data moved to PEB 7
libertas: 00:19:88:44:70:bd, fw 9.70.7p0, cap 0x00000303
libertas_sdio mmc1:0001:1: wlan0: Features changed: 0x00004800 -> 0x00004000
libertas: wlan0: Marvell WLAN 802.11 adapter
udev: renamed network interface wlan0 to wlan1
libertas: assoc: bss   (null) not in scan results
ADDRCONF(NETDEV_UP): wlan1: link is not ready
ADDRCONF(NETDEV_CHANGE): wlan1: link becomes ready
------------[ cut here ]------------
WARNING: at net/sched/sch_generic.c:256 dev_watchdog+0x140/0x228()
NETDEV WATCHDOG: wlan1 (libertas_sdio): transmit queue 0 timed out
Modules linked in: ipv6 libertas_sdio libertas cfg80211 option lib80211 usb_wwan usbserial firmware_class ads7846
[<c0042fd8>] (unwind_backtrace+0x0/0xec) from [<c0065964>] (warn_slowpath_common+0x4c/0x64)
[<c0065964>] (warn_slowpath_common+0x4c/0x64) from [<c0065a10>] (warn_slowpath_fmt+0x30/0x40)
[<c0065a10>] (warn_slowpath_fmt+0x30/0x40) from [<c0353d90>] (dev_watchdog+0x140/0x228)
[<c0353d90>] (dev_watchdog+0x140/0x228) from [<c006f39c>] (run_timer_softirq+0x18c/0x230)
[<c006f39c>] (run_timer_softirq+0x18c/0x230) from [<c006ab00>] (__do_softirq+0x74/0x120)
[<c006ab00>] (__do_softirq+0x74/0x120) from [<c006acd8>] (irq_exit+0x40/0x94)
[<c006acd8>] (irq_exit+0x40/0x94) from [<c003907c>] (asm_do_IRQ+0x7c/0xa0)
[<c003907c>] (asm_do_IRQ+0x7c/0xa0) from [<c003e4f4>] (__irq_svc+0x34/0xa0)
Exception stack(0xc0577f18 to 0xc0577f60)
7f00:                                                       001a13b9 00000000
7f20: 001a13b9 00000000 c05b8090 00000003 00000003 c05b7f90 c05b8094 413fc082
7f40: 00000000 00000000 3b9ac9ff c0577f60 c004e034 c004e040 60000053 ffffffff
[<c003e4f4>] (__irq_svc+0x34/0xa0) from [<c004e040>] (omap3_enter_idle+0x10c/0x144)
[<c004e040>] (omap3_enter_idle+0x10c/0x144) from [<c004e1e4>] (omap3_enter_idle_bm+0x134/0x17c)
[<c004e1e4>] (omap3_enter_idle_bm+0x134/0x17c) from [<c02d636c>] (cpuidle_idle_call+0xac/0x10c)
.....

Then I tried to scan the available wifi with my verdex and my overo and I obtained:

FOR THE OVERO:
root@overo:~# iwlist wlan1 scan
wlan1     Scan completed :
          Cell 01 - Address: 00:11:5C:6B:9C:90
                    Channel:11
                    Frequency:2.462 GHz (Channel 11)
                    Quality=70/70  Signal level=-29 dBm
                    Encryption key:off
                    ESSID:"VERDEX"
                    Bit Rates:1 Mb/s; 2 Mb/s; 5.5 Mb/s; 6 Mb/s; 9 Mb/s
                              11 Mb/s; 12 Mb/s; 18 Mb/s
                    Bit Rates:24 Mb/s; 36 Mb/s; 48 Mb/s; 54 Mb/s
                    Mode:Master
                    Extra:tsf=0000000021b341cc
                    Extra: Last beacon: 296ms ago
                    IE: Unknown: 0006564552444558
                    IE: Unknown: 010882848B0C12961824
                    IE: Unknown: 03010B
                    IE: Unknown: 2A0100
                    IE: Unknown: 32043048606C
                    IE: Unknown: 851E000084000F00FF0319006170000000000000000000000000000001000025
                    IE: Unknown: DD06004096010100
                    IE: Unknown: DD050040960304
                    IE: Unknown: DD050040960B01
                    IE: Unknown: DD180050F2020101810003A4000027A4000042435E0062322F00

For the VERDEX:
 Cell 01 - Address: 00:11:5C:6B:9C:90
                    ESSID:"VERDEX"
                    Mode:Managed
                    Frequency:2.462 GHz (Channel 11)
                    Quality:0/10  Signal level=-35 dBm  Noise level=-96 dBm
                    Encryption key:off
                    Bit Rates:54 Mb/s
                    Extra:extra_ie
And Finally I obtained repetitively this message on my overo:
root@overo:~# libertas: tx watch dog timeout
libertas: tx watch dog timeout
libertas: tx watch dog timeout
libertas: tx watch dog timeout
libertas: tx watch dog timeout
...

Do you have any idea of what i'm doing wrong on my overo?

Thanks in advance

Augustin