Hi Phil,
Out of the box I could run Steve's xfce image and reproduce the issue with the ping flood test. There would have been no way for me to run it for an hour without it crashing, it seemed to happen rather quickly.
I first experienced this issue when running my test application that puts about a 30% load on the processor and passes a large amount of data over the ethernet interface. I ended up narrowing it down to the ping test that could cause the problem.
I would suspect that it is a timing issue and not so much a heat issue. I can do a limited amount of testing to come up with a better solution if my unit is a better failure case, but it seems like it can be reproduced pretty easily on other targets.
With the patch that Scott provided, I haven't seen the problem occur again.

I also agree that when the issue occurred I could bring the interface down and back up again and the device would go return to a working state, but that wasn't acceptable for my application.

On Thu, Mar 28, 2013 at 11:06 AM, Philipp Lutz <philipp.lutz@dlr.de> wrote:
So finally I also ran into this issue when I begun working with the DuoVeros including the network connection....
I applied your patch and made the driver chatty. Find attached the kernel log with smsc911x related messages from booting until the ethernet-connection was dropped.

You know what's funny? I desperately tried to reproduce the issue when I read about it on the mailing list here and when my colleague finally experienced it. But I wasn't able, even after 1h of flood pinging (alex0486@bellsouth.net claimed that he could reproduce the issue with that).
But as soon as my colleague and I did the same thing on the Gumstix (compiling a bigger piece of software) I ran into the same trouble.
This means that the Gumstix became really hot (yes, we use the big heatspreader) and cpu-freq was clocking it to 1 GHz, in my case /sys/devices/system/cpu/cpu0/cpufreq/cpuinfo_cur_freq tells me "1008000".
Clocking up the CPU requires also the system clock and other clocks to go up, which could lead to timing-issues. The resulting heat could lead to thermal problems affecting the networking (PHY or MAC, or both). I don't think the latter makes any sense.
I can't reproduce the error when I work with a low CPU clock (cpu governer: powersave):
$ echo powersave > /sys/devices/system/cpu/cpu0/cpufreq/scaling_governor
What about you guys (particularly alex0486@bellsouth.net)? Can you still reproduce the issue?

Btw.: after running into the issue when I down the interface and up it again, it's also working again.


-------- Original Message --------
Subject: Re: [Gumstix-users] Duovero ethernet dropping connection
From: jumpnowdev <scott@jumpnowtek.com>
To: gumstix-users@lists.sourceforge.net
Date: 03/13/2013 08:53 AM
A little research on the gpmc values currently set in u-boot.


Look at the duovero tab. I wasn't 100% on the 200 MHz GPMC_FCLK.
And don't trust that spreadsheet too much. I was just making some 

Here's the hack patch I'm using that keeps the nic up for now


And another patch to enable the smsc911x driver debugging


That's all I've done so far. 

Some unexpected work showed up recently and I've been really busy.

I'm not even sure if the gpmc values are the problem. It was just a 
suggestion from Ash worth taking a look at.

View this message in context: http://gumstix.8.n6.nabble.com/Duovero-ethernet-dropping-connection-tp4966633p4966991.html
Sent from the Gumstix mailing list archive at Nabble.com.

Everyone hates slow websites. So do we.
Make your web apps faster with AppDynamics
Download AppDynamics Lite for free today:
gumstix-users mailing list

Own the Future-Intel&reg; Level Up Game Demo Contest 2013
Rise to greatness in Intel's independent game demo contest.
Compete for recognition, cash, and the chance to get your game
on Steam. $5K grand prize plus 10 genre and skill prizes.
Submit your demo by 6/6/13. http://p.sf.net/sfu/intel_levelupd2d
gumstix-users mailing list