I e-mailed the Linaro list some time back, and my understanding is that Overo is a "community-supported" system. This means that Gumstix is primarily responsible for ongoing support, hence the Git repo you found. Watching the list, my best guess is that they like the idea in principle but find Yocto more practical and so they keep it maintained. Steve and Ash are the ones I would ask for more detail.

My 2c,

On Feb 17, 2013 8:52 PM, "Brett Hemes" <brett.hemes@gmail.com> wrote:
Hello all,

I have been away from the scene for a year or so due to time constraints but am back.  After spending that much time off I decided to try and get a newer image and (right or wrong) decided to try out Linaro after browsing the users wiki.  Additionally I found a tutorial here: http://www.ros.org/wiki/groovy/Installation/Linaro/Source and thought "awesome! this should be nice and easy and when I'm done I'll have a working build of ROS along with my shiny new Linaro distro."  Things are not so.

Basically I am trying to follow the instructions at the following link below to get ROS Mobile variant working on the Overo Fire:
The "Newest" Linaro image from github.com/gumstix/Gumstix-Overo-Linaro.git keeps throwing blocking warnings, kernel panics, and a good ole "apt-get update" completely breaks the image (i.e., hangs with a file io error into a kernel panic and then the sd card won't boot again)

I have tried a multitude of other hardware pack / rootfs combinations from the Linaro site over the past weeks and the best I could do was to build ros-base on Linaro 11.09 (hwpack_linaro-overo_20110926 + alip-n-tar-20110929)
This was exciting but I run into issues with missing packages in apt as well as build issues with other dependencies when trying to build/install any variants past ros-base (e.g., robot or mobile).  The suggested (but unstable for me) image from the tutorial has a version of Precise while the issues I am having are in Natty so my current train of thought is that my old (but stable) version is to blame..

...I was going to try using rootstock to put a Ubuntu 12.04 rootfs on the gumstix with the angstrom kernel but it seems that rootstock is now depreciated? ... I guess this is what happens if you take a year off playing with this stuff.

Sorry about the rambling, I am just a bit desperate at this point after a few weeks of flashing sd cards :)

I guess my biggest question is why am I having stability problems with the github Gumstix Linaro image;  any help on this would be greatly appreciated. 
Other questions I have are
1) is Linaro still even supporting Overo?  The newest version of Linaro on their release server seems to be 12.03 which is over a year old while beagle and panda boards are getting much newer releases.
2) anyone know what the letters (m, n, o) in the Linaro release file names designate.  I seem to have had the most luck with the n's but don't know what it means...


The Go Parallel Website, sponsored by Intel - in partnership with Geeknet,
is your hub for all things parallel software development, from weekly thought
leadership blogs to news, videos, case studies, tutorials, tech docs,
whitepapers, evaluation guides, and opinion stories. Check out the most
recent posts - join the conversation now. http://goparallel.sourceforge.net/
gumstix-users mailing list