Good morning Andrew! Have you tried from scratch (ie, fresh repo init/sync)? 
I am too very curious to find out why this is happening. 

Adam


On Mon, Jan 13, 2014 at 9:09 PM, acsmith <acsmith@stanford.edu> wrote:
Well I did a bit more playing around, basically trying to either download the
firmware manually or figure out exactly what is being downloaded.  After
cleaning virtual/kernel (cleansstate and cleanall), it removes the directory
downloads/git2/github.com.gumstix.linux.git and file
downloads/git2/github.com.gumstix.linux.git.done.  So I made an empty
directory with the same name and used touch to create the .done file.  Then
I ran bitbake -c configure virtual/kernel.  This is what came out

NOTE: Resolving any missing task queue dependencies
NOTE: Preparing runqueue
NOTE: Executing SetScene Tasks
NOTE: Executing RunQueue Tasks
WARNING: Failed to fetch URL
git://github.com/gumstix/linux.git;branch=omap-3.2;protocol=git, attempting
MIRRORS if available
ERROR: Fetcher failure: Fetch command failed with exit code 128, output:
fatal: Not a git repository (or any of the parent directories): .git

ERROR: Function failed: Fetcher failure for URL:
'git://github.com/gumstix/linux.git;branch=omap-3.2;protocol=git'. Unable to
fetch URL from any source.
ERROR: Logfile of failure stored in:
/home/andrew/yocto-dylan/build/tmp/work/pepper-poky-linux-gnueabi/linux-gumstix/3.2-r1/temp/log.do_fetch.17053
ERROR: Task 2
(/home/andrew/yocto-dylan/poky/meta-gumstix/recipes-kernel/linux/linux-gumstix_3.2.bb,
do_fetch) failed with exit code '1'
NOTE: Tasks Summary: Attempted 222 tasks of which 221 didn't need to be
rerun and 1 failed.
No currently running tasks (184 of 225)

Summary: 1 task failed:

/home/andrew/yocto-dylan/poky/meta-gumstix/recipes-kernel/linux/linux-gumstix_3.2.bb,
do_fetch
Summary: There was 1 WARNING message shown.
Summary: There were 2 ERROR messages shown, returning a non-zero exit code.

So indeed it looks as though it's trying to grab the omap-3.2 branch instead
of the am335x-3.2 branch.  Here's a copy of my
/home/andrew/yocto-dylan/poky/meta-gumstix/recipes-kernel/linux/linux-gumstix_3.2.bb
file.

require linux.inc

DESCRIPTION = "Linux kernel for OMAP processors"
KERNEL_IMAGETYPE = "uImage"

COMPATIBLE_MACHINE = "pepper"

BOOT_SPLASH ?= "logo_linux_clut224-generic.ppm"
PV = "3.2"

S = "${WORKDIR}/git"

SRCREV = "${AUTOREV}"
SRC_URI = "git://github.com/gumstix/linux.git;branch=am335x-3.2;protocol=git
\
           file://defconfig \
           file://${BOOT_SPLASH} \
           "

Pretty weird.  At this point it might be a lot easier to start from scratch
but I'm really interested as to what is causing the problems.
Comments/suggestions would be greatly appreciated.

Thanks,

Andrew



--
View this message in context: http://gumstix.8.x6.nabble.com/Gumstix-Pepper-Dylan-Kernel-Fail-tp4968541p4968565.html
Sent from the Gumstix mailing list archive at Nabble.com.

------------------------------------------------------------------------------
CenturyLink Cloud: The Leader in Enterprise Cloud Services.
Learn Why More Businesses Are Choosing CenturyLink Cloud For
Critical Workloads, Development Environments & Everything In Between.
Get a Quote or Start a Free Trial Today.
http://pubads.g.doubleclick.net/gampad/clk?id=119420431&iu=/4140/ostg.clktrk
_______________________________________________
gumstix-users mailing list
gumstix-users@lists.sourceforge.net
https://lists.sourceforge.net/lists/listinfo/gumstix-users