Can you try mounting the boot partition like I did? The following is the image I used.

https://s3-us-west-2.amazonaws.com/yocto/usb-otg-mass-storage/MLO
https://s3-us-west-2.amazonaws.com/yocto/usb-otg-mass-storage/gumstix-console-image-overo.tar.bz2
https://s3-us-west-2.amazonaws.com/yocto/usb-otg-mass-storage/u-boot.img
https://s3-us-west-2.amazonaws.com/yocto/usb-otg-mass-storage/uImage
https://s3-us-west-2.amazonaws.com/yocto/usb-otg-mass-storage/defconfig


On Thu, Mar 27, 2014 at 12:37 PM, daveti <dave.jing.tian@gmail.com> wrote:
[  117.255401] udc musb-hdrc: registering UDC driver [g_mass_storage]
[  117.255462]  gadget: adding config #1 'Linux File-Backed
Storage'/bf13d680
[  117.255767]  lun0: open backing file: /home/root/daveti.img
[  117.256011]  gadget: Mass Storage Function, version: 2009/09/11
[  117.274444]  gadget: Number of LUNs=1
[  117.278350]  lun0: LUN: removable file: /home/root/daveti.img
[  117.293701]  gadget: I/O thread pid: 176
[  117.293792]  gadget: adding 'Mass Storage Function'/ce09f840 to config
'Linux File-Backed Storage'/bf13d680
[  117.293823]  gadget: cfg 1/bf13d680 speeds: high full
[  117.293853]  gadget:   interface 0 = Mass Storage Function/ce09f840
[  117.293884]  gadget: Mass Storage Gadget, version: 2009/09/11
[  117.305267]  gadget: userspace failed to provide iSerialNumber
[  117.311492]  gadget: g_mass_storage ready
[  117.337921] twl4030_usb twl4030_usb: twl4030_phy_resume
[  117.338012] musb-hdrc musb-hdrc: MUSB HDRC host driver
[  117.353363] musb-hdrc musb-hdrc: new USB bus registered, assigned bus
number 2
[  117.369995] musb-hdrc musb-hdrc: supports USB remote wakeup
[  117.370147] usb usb2: default language 0x0409
[  117.370208] usb usb2: udev 1, busnum 2, minor = 128
[  117.370239] usb usb2: New USB device found, idVendor=1d6b, idProduct=0002
[  117.382385] usb usb2: New USB device strings: Mfr=3, Product=2,
SerialNumber=1
[  117.398040] usb usb2: Product: MUSB HDRC host driver
[  117.410827] usb usb2: Manufacturer: Linux 3.5.7-yocto-standard musb-hcd
[  117.421997] usb usb2: SerialNumber: musb-hdrc
[  117.437713] usb usb2: usb_probe_device
[  117.440338] usb usb2: configuration #1 chosen from 1 choice
[  117.440429] usb usb2: adding 2-0:1.0 (config #1, interface 0)
[  117.440734] hub 2-0:1.0: usb_probe_interface
[  117.440765] hub 2-0:1.0: usb_probe_interface - got id
[  117.440795] hub 2-0:1.0: USB hub found
[  117.444793] hub 2-0:1.0: 1 port detected
[  117.464294] hub 2-0:1.0: standalone hub
[  117.464355] hub 2-0:1.0: individual port power switching
[  117.464355] hub 2-0:1.0: no over-current protection
[  117.464385] hub 2-0:1.0: Single TT
[  117.464385] hub 2-0:1.0: TT requires at most 8 FS bit times (666 ns)
[  117.464416] hub 2-0:1.0: power on to power good time: 10ms
[  117.464477] hub 2-0:1.0: 100mA bus power budget for each child
[  117.464508] hub 2-0:1.0: local power source is good
[  117.464538] hub 2-0:1.0: enabling power on all ports
[  117.563171] hub 2-0:1.0: state 7 ports 1 chg 0000 evt 0000
[  120.008392] hub 2-0:1.0: hub_suspend
[  120.008453] usb usb2: bus auto-suspend, wakeup 1
[  120.009521] twl4030_usb twl4030_usb: twl4030_phy_suspend
root@overo:/lib/modules/3.5.7-yocto-standard/kernel/drivers/usb/gadget$


There should be sth wrong with hub2-0:1.0 config. It is suspended for
certain reasons....




--
View this message in context: http://gumstix.8.x6.nabble.com/defconfig-for-overo-as-usb-gadget-mass-storage-tp4968995p4968998.html
Sent from the Gumstix mailing list archive at Nabble.com.

------------------------------------------------------------------------------
_______________________________________________
gumstix-users mailing list
gumstix-users@lists.sourceforge.net
https://lists.sourceforge.net/lists/listinfo/gumstix-users