Hi Francesco, I thought I responded to your question, but apparently I haven't!
If you are familiar with Gumstix Yocto Project, you should try out meta-ros
It will let you cross-compile the latest ROS for your Overo. 

Adam



On Mon, Mar 31, 2014 at 6:45 AM, francesco [via Gumstix] <[hidden email]> wrote:
Hi all,

recently I got  an Overo AirSTORM COM and a Robovero, with Linaro and ROS pre-installed (*2 for details).
Everything is ok, but ROS doesn't work well.

In particular, I can run roscore, rosrun, but catkin_make doesn't work.

When I run  catkin_make at the root of my ROS workspaces, I always obtain:
$> #### Running command: "make -j1" in "/root/catkin_ws2/build"  (*1 for details)
Even if I apply this advice, nothing changes.


Furthermore, I checked the links like ( http://wiki.gumstix.org/index.php?title=ROS ,  http://wiki.ros.org/groovy/Installation/Linaro/Source)
and I found that some steps proposed in these links had not been performed on my boards ( e.g. step 8 and 9 in the first link).
I applied the corrections in steps 8 and 9 but it didn't solve the issue. In particular, if I run  $>python os_detect.py   I still obtain ubuntu as answer.

Any ideas about how to make the ROS installation  works?

Thanks,
Francesco.

PS: Details
------------------------------------------
(*1)
Detailed Input:
root@linaro-alip:~/catkin_ws2# catkin_make
Detailed Output:
Base path: /root/catkin_ws2
Source space: /root/catkin_ws2/src
Build space: /root/catkin_ws2/build
Devel space: /root/catkin_ws2/devel
Install space: /root/catkin_ws2/install
####
#### Running command: "make -j1" in "/root/catkin_ws2/build"
####

-----------------------------------------------------
(*2)
Datails of my System:
ROS: Groovy

Linaro:
Linux linaro-alip 3.5.0-2-linaro-omap #2~ci+121210190143 PREEMPT Mon Dec 10 11:03:27 PST 2012 armv7l armv7l armv7l GNU/Linux

Overo AirSTORM COM ( GUM3703A-R3950 )
Robovero (PKG30019 )


If you reply to this email, your message will be added to the discussion below:
http://gumstix.8.x6.nabble.com/ROS-pre-installed-on-Linaro-Overo-AirSTORM-Robovero-tp4969009.html
To start a new topic under Gumstix, email [hidden email]
To unsubscribe from Gumstix, click here.
NAML



View this message in context: Re: ROS pre-installed on Linaro: Overo AirSTORM + Robovero
Sent from the Gumstix mailing list archive at Nabble.com.