The Yocto images on the site, like all things Gumstix, don't actually work out-of-the-box (the default display manager doesn't let you log in with no password, and you have to guess what the default user password is because they forgot to document it).

Log in as root through a terminal (hit ctrl-alt-f1 or do it over the serial port) then change the root password to something not empty (type "passwd"). You may then *attempt* to log in to X using root and the new password.

I say "attempt" because the last time I tried logging in to X as root on the Yocto images I got stuck at a black screen. I didn't bother trying to find out what was wrong because I also found that the package manager, 'smart', is slow to the point of being counterproductive (8 minutes to update libjpeg, about an hour to update 10 minor packages) so I ended up using the Linaro build instead.

Yet another Gumstix QA win (again: Gumstix, all I ask is that you use your products *once*).

It may be straightforward to get Yocto up and running, I don't know. Personally, I found the Linaro image to be more productive (although note: I have not tried the actual Linaro image from the Gumstix site, as I presumed it would be broken like everything else, so I grabbed it from Linaro git as per the instructions here: - the Gumstix site images might be fine). Linaro's been a breeze and 'apt-get' is much smoother than 'smart'.

But, I digress... anyways, try changing root pw to non-blank in console. Post back if it works or not.

Good luck.


On Sun, Oct 27, 2013 at 8:20 PM, Hyon Lim <> wrote:
I've downloaded images for Duovero (Yocto).
Writing image was successful, but login failed.

id: root / pw: <nothing>

What is the problem?


This mail was written in mobile phone.

October Webinars: Code for Performance
Free Intel webinars can help you accelerate application performance.
Explore tips for MPI, OpenMP, advanced profiling, and more. Get the most from
the latest Intel processors and coprocessors. See abstracts and register >
gumstix-users mailing list