first i should say how i solved the problem with $bitbake task-gstreamer-ti
in file someone made this comment

             # '.make' target was used in CE < 2.26, but its no longer
             # supported in CE >= 2.26. Now we are moved to >=2.26
             # hence commenting out the .make target.
             #         .make clean

I uncommented the last line and it worked.

then i followed your steps to make sure that the dsp modules are compiled for the caspapx kernel. however i get the attached error message. the message doesn't show up if i don't make the changes proposed by you.

i'm really sorry for damping here error messages but i truly don't know what to do with them. thanks a lot for your valuable help!

| echo Building kernel side code using kbuild
| Building kernel side code using kbuild
| make PROFILE=DEBUG -C /home/gonber/overo-oe/tmp/sysroots/overo-angstrom-linux-gnueabi/kernel SUBDIRS=/home/gonber/overo-oe/tmp/work/overo-angstrom-linux-gnueabi/ti-dsplink-1_1_65_00_03-r101i/dsplink_linux_1_65_00_03/dsplink/gpp/src ARCH=arm modules
| make[1]: Entering directory `/home/gonber/overo-oe/tmp/sysroots/overo-angstrom-linux-gnueabi/kernel'
| make[1]: *** No rule to make target `modules'.  Stop.
| make[1]: Leaving directory `/home/gonber/overo-oe/tmp/sysroots/overo-angstrom-linux-gnueabi/kernel'
| make: *** [debug] Error 2
| ERROR: Function do_compile failed
NOTE: package ti-dsplink-1_1_65_00_03-r101i: task do_compile: Failed
ERROR: TaskFailed event exception, aborting
ERROR: Build of /home/gonber/overo-oe/ do_compile failed
ERROR: Task 624 (/home/gonber/overo-oe/, do_compile) failed with 256
ERROR: '/home/gonber/overo-oe/' failed
ERROR: '/home/gonber/overo-oe/' failed

On Mon, Jul 18, 2011 at 4:20 PM, ScottEllis <> wrote:

Sorry about that. I forgot you also need to clean the dsp kernel modules
or they will still be built for the wrong kernel.

Run a script like this before you change your kernel

Modify it for your image.

Then if you are going from linux-omap3-2.6.36 to linux-omap3-2.6.34, you can
add a PREFERRED_VERSION line in local.conf as I originally posted.

If you want to switch to the linux-omap-psp or linux-omap3-caspapx
kernels, then modify overo-oe/

Change this line
PREFERRED_PROVIDER_virtual/kernel = "linux-omap3"

to this
PREFERRED_PROVIDER_virtual/kernel = "linux-omap-psp"

or this
PREFERRED_PROVIDER_virtual/kernel = "linux-omap3-caspapx"

Then rebuild your image with something like bitbake omap3-console-image

You can verify that the modules were correctly built and packaged into your
rootfs before you copy to the SD card.

For the omap3-console-image, look for this directory


Look in 'files-in-image.txt'. If you search for cmem, you should find a
like this.

total 1464
drwxrwxr-x  2 root root    4096 Jul 18 08:59 .
drwxrwxr-x 18 root root    4096 Jul 18 08:52 ..
-rwxr-xr-x  1 root root  152206 Jul 18 08:51 cmemk.ko
-rwxr-xr-x  1 root root 1140680 Jul 18 08:54 dsplinkk.ko
-rwxr-xr-x  1 root root   96222 Jul 18 08:55 lpm_omap3530.ko
-rwxr-xr-x  1 root root   93620 Jul 18 08:51 sdmak.ko

Note the 2.6.34 subdirectory. This was a linux-omap3-2.6.34 kernel build.
If the dsp modules weren't built correctly, this wouldn't match your kernel
version. Your failed image probably had these modules under 2.6.36, the
kernel they were built for.


View this message in context:
Sent from the Gumstix mailing list archive at

AppSumo Presents a FREE Video for the SourceForge Community by Eric
Ries, the creator of the Lean Startup Methodology on "Lean Startup
Secrets Revealed." This video shows you how to validate your ideas,
optimize your ideas and identify your business strategy.
gumstix-users mailing list