I have the same issue.  Is there a way to verify that my problem is a defect and not something I did?  And if anyone has sent back an overo, how long does it take to get it back?
Message: 3
Date: Thu, 7 Jul 2011 16:20:37 +0200
From: Simon Wilks <sjwilks@gmail.com>
Subject: [Gumstix-users] Overo/Tobi ethernet issue: "Net: No ethernet
To: gumstix-users@lists.sourceforge.net
Content-Type: text/plain; charset="iso-8859-1"

Hi All,

I have seen this being reported by others and just received a Gumstix Overo
along with the Tobi expansion board and also cannot use ethernet. When it
boots up I get:
No EEPROM on expansion board
Die ID #4c2a0004000000000403951c0701701a
Net:   No ethernet found.

in the console. I have tried everything I could find in the mailing lists
(including re-seating the Overo board) but to no avail. I am running
everything as it came, ie: I have not tried new images etc. as it seems from
other's experience that it doesn't change anything anyway. Other than this
all seems to work fine.

So this Email serves three purposes:
1) To let others and Gumstix know that there is one more person having an
issue with the Tobi (or could it be the Overo?);
2) Hoping someone has a magical solution; and
3) As a lead-up to returning it under warrantee.