I have checked and openssl will build with Ubuntu 10.04. I therefore believe it is a problem related to the new Ubuntu, potentially an update in gcc/g++. I have logged a bug with the openembedded team.

Cheers