J,

I don't know what to say anymore!

After following the instructions at http://www.sakoman.com/category/8-gnome-daily-builds-r13.html, I used them to redo the SD Card. I removed the SD Card (right click on the SD Card icon then chose "safely remove parent ...") then insert it into Gumstix card slot; connect the Gumstix's USB, launch the pico emulator (picocom -b 115200 /dev/ttyUSB0), power up the Tobi board, break into boot environment when "Hit any key to stop autoboot:" is displayed, type "nand erase 240000 20000" then "reset". But still I am having the booting process looping indefinitely as shown below:

Texas Instruments X-Loader 1.5.1 (Mar 19 2012 - 13:44:43)
OMAP3530-GP ES3.1

Board revision: 1
Reading boot sector
Loading u-boot.bin from mmc


U-Boot 2011.09 (Mar 19 2012 - 13:46:06)

OMAP3530-GP ES3.1, CPU-OPP2, L3-165MHz, Max CPU Clock 720 mHz

Gumstix Overo board + LPDDR/NAND
I2C:   ready
DRAM:  512 MiB
NAND:  512 MiB
MMC:   OMAP SD/MMC: 0
*** Warning - bad CRC, using default environment


In:    serial
Out:   serial
Err:   serial
Board revision: 1
Direct connection on mmc2
No EEPROM on expansion board
Die ID #
647600040000000004037f660700700a

Net:   smc911x-0
Hit any key to stop autoboot:  0
� tصb� $U
             @ @ @ D��` @ @

Texas Instruments X-Loader 1.5.1 (Mar 19 2012 - 13:44:43)
OMAP3530-GP ES3.1

Board revision: 1
Reading boot sector
Loading u-boot.bin from mmc


U-Boot 2011.09 (Mar 19 2012 - 13:46:06)

OMAP3530-GP ES3.1, CPU-OPP2, L3-165MHz, Max CPU Clock 720 mHz

Gumstix Overo board + LPDDR/NAND
I2C:   ready
DRAM:  512 MiB
� tصb� $U
             @ @ @ D��` @ �

Texas Instruments X-Loader 1.5.1 (Mar 19 2012 - 13:44:43)
OMAP3530-GP ES3.1

Board revision: 1
Reading boot sector
Loading u-boot.bin from mmc


U-Boot 2011.09 (Mar 19 2012 - 13:46:06)

OMAP3530-GP ES3.1, CPU-OPP2, L3-165MHz, Max CPU Clock 720 mHz

Gumstix Overo board + LPDDR/NAND
I2C:   ready
DRAM:  512 MiB
NAND:  512 MiB
MMC:   OMAP SD/MMC: 0
*** Warning - bad CRC, using default environment


In:    serial
Out:   serial
Err:   serial
Board revision: 1
Direct connection on mmc2
No EEPROM on expansion board
Die ID #647600040000000004037f660700700a

Net:   smc911x-0
Hit any key to stop autoboot:  0
� tصb� $U
             @ @ @ D��` @ @

Texas Instruments X-Loader 1.5.1 (Mar 19 2012 - 13:44:43)
OMAP3530-GP ES3.1

Board revision: 1
Reading boot sector
Loading u-boot.bin from mmc


U-Boot 2011.09 (Mar 19 2012 - 13:46:06)

OMAP3530-GP ES3.1, CPU-OPP2, L3-165MHz, Max CPU Clock 720 mHz

Gumstix Overo board + LPDDR/NAND
I2C:   ready
DRAM:  512 MiB
� tصb� $U
             @ @ @ D��` @ @

Texas Instruments X-Loader 1.5.1 (Mar 19 2012 - 13:44:43)
OMAP3530-GP ES3.1

Board revision: 1
Reading boot sector
Loading u-boot.bin from mmc


U-Boot 2011.09 (Mar 19 2012 - 13:46:06)

OMAP3530-GP ES3.1, CPU-OPP2, L3-165MHz, Max CPU Clock 720 mHz

Gumstix Overo board + LPDDR/NAND
I2C:   ready
DRAM:  512 MiB
NAND:  512 MiB
MMC:   OMAP SD/MMC: 0
*** Warning - bad CRC, using default environment


In:    serial
Out:   serial
Err:   serial
Board revision: 1
Direct connection on mmc2
No EEPROM on expansion board
Die ID #647600040000000004037f660700700a

Net:   smc911x-0
Hit any key to stop autoboot:  0
� tصb� $U
             @ @ @ D��` @ �

Texas Instruments X-Loader 1.5.1 (Mar 19 2012 - 13:44:43)
OMAP3530-GP ES3.1

Board revision: 1
Reading boot sector
Loading u-boot.bin from mmc


U-Boot 2011.09 (Mar 19 2012 - 13:46:06)

OMAP3530-GP ES3.1, CPU-OPP2, L3-165MHz, Max CPU Clock 720 mHz

Gumstix Overo board + LPDDR/NAND
I2C:   ready
DRAM:  512 MiB
� tصb� $U
             @ @ @ D��` @ @

Texas Instruments X-Loader 1.5.1 (Mar 19 2012 - 13:44:43)
OMAP3530-GP ES3.1

Board revision: 1
Reading boot sector
Loading u-boot.bin from mmc


U-Boot 2011.09 (Mar 19 2012 - 13:46:06)

OMAP3530-GP ES3.1, CPU-OPP2, L3-165MHz, Max CPU Clock 720 mHz

Gumstix Overo board + LPDDR/NAND
I2C:   ready
DRAM:  512 MiB
NAND:  512 MiB
MMC:   OMAP SD/MMC: 0
*** Warning - bad CRC, using default environment


In:    serial
Out:   serial
Err:   serial
Board revision: 1
Direct connection on mmc2
No EEPROM on expansion board
Die ID #647600040000000004037f660700700a

Net:   smc911x-0
Hit any key to stop autoboot:  0
� tصb� $U
             @ @ @ D��` @ �

Texas Instruments X-Loader 1.5.1 (Mar 19 2012 - 13:44:43)
OMAP3530-GP ES3.1

Board revision: 1
Reading boot sector
Loading u-boot.bin from mmc


U-Boot 2011.09 (Mar 19 2012 - 13:46:06)

OMAP3530-GP ES3.1, CPU-OPP2, L3-165MHz, Max CPU Clock 720 mHz

Gumstix Overo board + LPDDR/NAND
I2C:   ready
DRAM:  512 MiB
NAND:  512 MiB
MMC:   OMAP SD/MMC: 0
*** Warning - bad CRC, using default environment


In:    serial
Out:   serial
Err:   serial
Board revision: 1
Direct connection on mmc2
No EEPROM on expansion board
Die ID #647600040000000004037f660700700a

Net:   smc911x-0
Hit any key to stop autoboot:  0

####################################################

The "printenv" looks as displayed below:

Overo # printenv
baudrate=115200
bootcmd=if mmc rescan ${mmcdev}; then if run loadbootscript; then run bootscript; else if run loaduimage; then run mmcboot; else run nandboot; fi; fi; else run nandboot; fi
bootdelay=5
bootscript=echo Running bootscript from mmc ...; source ${loadaddr}
console=ttyO2,115200n8
defaultdisplay=dvi
dieid#=647600040000000004037f660700700a
dvimode=1024x768MR-16@60
ethact=smc911x-0
loadaddr=0x82000000
loadbootscript=fatload mmc ${mmcdev} ${loadaddr} boot.scr
loaduimage=fatload mmc ${mmcdev} ${loadaddr} uImage
mmcargs=setenv bootargs console=${console} ${optargs} mpurate=${mpurate} vram=${vram} omapfb.mode=dvi:${dvimode} omapdss.def_disp=${defaultdisplay} root=${mmcroot} rootfstype=${mmcrootfstype}
mmcboot=echo Booting from mmc ...; run mmcargs; bootm ${loadaddr}
mmcdev=0
mmcroot=/dev/mmcblk0p2 rw
mmcrootfstype=ext3 rootwait
mpurate=500
nandargs=setenv bootargs console=${console} ${optargs} mpurate=${mpurate} vram=${vram} omapfb.mode=dvi:${dvimode} omapdss.def_disp=${defaultdisplay} root=${nandroot} rootfstype=${nandrootfstype}
nandboot=echo Booting from nand ...; run nandargs; nand read ${loadaddr} 280000 400000; bootm ${loadaddr}
nandroot=ubi0:rootfs ubi.mtd=4
nandrootfstype=ubifs
stderr=serial
stdin=serial
stdout=serial
vram=12M

Environment size: 1312/131068 bytes

##########################################################

Please help out!!! If I can not boot the prebuild image, I won't be able to use the use my Gumstix therefore will be stucked with my research project nor will meet my goal!

Please figure out what might be the problem; either software or hardware.

Thank you in advance,
Gutembert.
 

On Fri, Apr 20, 2012 at 12:20 AM, Gutembert nganpet <[hidden email]> wrote:
Thank you J,

Will do so. Concerning redoing the SD Card, this time I'll but with a different SD Card (Sandisk) that I will buy tomorrow.

Appreciated,
Gutembert.


On Thu, Apr 19, 2012 at 11:43 PM, j [via Gumstix] <[hidden email]> wrote:
On 04/19/2012 02:04 PM, Gutembert wrote:
J,

>nand erase 240000 20000
>reset


Yes I did; this is how: after redoing the card, I inserted it to the Water COM, booted the COM, just after few seconds, I broke into the boot environment (overo#), then I did the overo# nand erase 240000 20000 and overo# reset.

>Working:
http://www.sakoman.com/category/8-gnome-daily-builds-r13.html

I believe this uses kernel 3.X!!

No clue what they are using right now on there but I do believe it is at least 3.0.X
I just know Steve's stuff works


Just to ensure:
1. My default x-loader (while booting with NAND) is 1.5 does it have anything to do with my Gumstix's kernel?
the gumstix kernel is uImage x-loader is MLO


2. During the booting process, will the overo-oe/sources/ directory be accessible? "I have almost empty it (overo-oe/sources/       directory) due to the fact that its content has taken a lot of GB!!!"

Boot process of what? Your build machine?
If you are asking on the actual overo then no it wont be as that has nothing to do with a running system it is only related to building images on a build machine. Unless I do not get that question, if I do then you are confusing to different things together.



3. It seems like I am running out of storage memory and having a slow machine. I made my mind, I am going for a Mac Book Pro Qua-core. I am planning to use VMWare for Ubuntu on Mac.

add this to your local.conf
INHERIT += "rm_work"



>Last thing I can think of is have you tried only this one card or have you tried multiple cards? As for some reason maybe you have >a bad card.

I have used two different SD Cards so far unsuccessfully but I think tomorrow, I will buy the sandisk brand since most people believe in it working.

If it is a no name brand then yes that could be the problem I use sandisk and kingston all class 4 or 6 cards and I run 32GB sdcards.



Thank you,
Gutembert.



On Thu, Apr 19, 2012 at 10:37 PM, j [via Gumstix] <[hidden email]> wrote:
On 04/19/2012 01:19 PM, Gutembert wrote:
Thanks J for your input,

You said: "Did you try booting with a cleared environment after re-doing the
sdcard?" could you please be more explicit on "a cleared environment"?

nand erase 240000 20000
reset



>Also did you copy the MLO first after the sdcard was created? Not sure
>if that script copies your files for you or not. MLO has to be the first
>thing copied on to the FAT partition of the sdcard.

According to the website, after the files have been downloaded, the will be automatically copied into the SD Card. I even listed the boot directory and those three files (MLO, u-boot.bin and uImage) were there!

Then if the script does that then what I was saying should not be the problem. I am sure Steve's script is properly setting up your card, unless their are variables to pass to it that you missed or typo'd on.


>My guess is the u-boot.bin is not right, as in a bad copy or bad
>build/download. As it seems to hang on that spot.

Could someone please provide with tested and working files?


Working:
http://www.sakoman.com/category/8-gnome-daily-builds-r13.html

Thanks,
Gutembert.
Last thing I can think of is have you tried only this one card or have you tried multiple cards? As for some reason maybe you have a bad card.



PS. My default x-loader (while booting with NAND) is 1.5 does it have anything to do with my Gumstix's kernel?
      During the booting process, will the overo-oe/sources/ directory be accessible? "I have almost empty it (overo-oe/sources/       directory) due to the fact that its content has taken a lot of GB!!!"
      Also the procedure of connecting/powering the Gumstix is first to run the kermit ... , connect then power on the Gumstix. What will be the procedure of disconnecting/power off the gumstix?

It seems like I am running out of storage memory and having a slow machine. I made my mind, I am going for a Mac Book Pro Qua-core. I am planning to use VMWare for Ubuntu on Mac.

On Thu, Apr 19, 2012 at 6:08 PM, j [via Gumstix] <[hidden email]> wrote:
On 04/19/2012 08:55 AM, Gutembert wrote:

> Steve,
>
> Before reading this post, I was at your website and I follow your
> instructions but still having troubles!
>
> When booting with SD Card partitioned using your instructions, I have
> something similar to this:
>
> Texas Instruments X-Loader 1.4.4ss (Aug 16 2011 - 09:50:42)
> OMAP3530-GP ES3.1
> Board revision: 1
> Reading boot sector
> Loading u-boot.bin from mmc
>
>
> U-Boot 2010.12 (Aug 16 2011 - 09:52:23)
>
> OMAP3530-GP ES3.1, CPU-OPP2, L3-165MHz, Max CPU Clock 720 mHz
> Gumstix Overo board + LPDDR/NAND
> I2C:   ready
> DRAM:  512 MiB
> NAND:  512 MiB
> MMC:   OMAP SD/MMC: 0
> � tصb� $U
>               @ @ @ D��` @ @
>
> Texas Instruments X-Loader 1.4.4ss (Aug 16 2011 - 09:50:42)
> OMAP3530-GP ES3.1
> Board revision: 1
> Reading boot sector
> Loading u-boot.bin from mmc
>
>
> U-Boot 2010.12 (Aug 16 2011 - 09:52:23)
>
> OMAP3530-GP ES3.1, CPU-OPP2, L3-165MHz, Max CPU Clock 720 mHz
> Gumstix Overo board + LPDDR/NAND
> I2C:   ready
> DRAM:  512 MiB
> NAND:  512 MiB
> MMC:   OMAP SD/MMC: 0
> � tصb� $U
>               @ @ @ D��` @ @
>
> Texas Instruments X-Loader 1.4.4ss (Aug 16 2011 - 09:50:42)
> OMAP3530-GP ES3.1
> Board revision: 1
> Reading boot sector
> Loading u-boot.bin from mmc
>
>
> U-Boot 2010.12 (Aug 16 2011 - 09:52:23)
>
> OMAP3530-GP ES3.1, CPU-OPP2, L3-165MHz, Max CPU Clock 720 mHz
> Gumstix Overo board + LPDDR/NAND
> I2C:   ready
> DRAM:  512 MiB
> NAND:  512 MiB
> MMC:   OMAP SD/MMC: 0
> � tصb� $U
>               @ @ � D��` @ @
>
> Texas Instruments X-Loader 1.4.4ss (Aug 16 2011 - 09:50:42)
> OMAP3530-GP ES3.1
> Board revision: 1
> Reading boot sector
> Loading u-boot.bin from mmc
>
>
> U-Boot 2010.12 (Aug 16 2011 - 09:52:23)
>
> OMAP3530-GP ES3.1, CPU-OPP2, L3-165MHz, Max CPU Clock 720 mHz
> Gumstix Overo board + LPDDR/NAND
> I2C:   ready
> DRAM:  512 MiB
> NAND:  512 MiB
> MMC:   OMAP SD/MMC: 0
> � tصb� $U
>               @ @ @ D��` @ @
>
> Texas Instruments X-Loader 1.4.4ss (Aug 16 2011 - 09:50:42)
> OMAP3530-GP ES3.1
> Board revision: 1
> Reading boot sector
> Loading u-boot.bin from mmc
>
>
> U-Boot 2010.12 (Aug 16 2011 - 09:52:23)
>
> OMAP3530-GP ES3.1, CPU-OPP2, L3-165MHz, Max CPU Clock 720 mHz
> Gumstix Overo board + LPDDR/NAND
> I2C:   ready
> DRAM:  512 MiB
> � tصb� $U
>               @ @ @ D��` @ @
>
> Texas Instruments X-Loader 1.4.4ss (Aug 16 2011 - 09:50:42)
> OMAP3530-GP ES3.1
> Board revision: 1
> Reading boot sector
> Loading u-boot.bin from mmc
>
>
> U-Boot 2010.12 (Aug 16 2011 - 09:52:23)
>
> OMAP3530-GP ES3.1, CPU-OPP2, L3-165MHz, Max CPU Clock 720 mHz
> Gumstix Overo board + LPDDR/NAND
> I2C:   ready
> DRAM:  512 MiB
> � tصb� $U
>               @ @ @ D��` @ @
>
> Texas Instruments X-Loader 1.4.4ss (Aug 16 2011 - 09:50:42)
> OMAP3530-GP ES3.1
> Board revision: 1
> Reading boot sector
> Loading u-boot.bin from mmc
>
>
> U-Boot 2010.12 (Aug 16 2011 - 09:52:23)
>
> OMAP3530-GP ES3.1, CPU-OPP2, L3-165MHz, Max CPU Clock 720 mHz
> Gumstix Overo board + LPDDR/NAND
> I2C:   ready
> DRAM:  512 MiB
> NAND:  512 MiB
> MMC:   OMAP SD/MMC: 0
> � tصb� $U
>               @ @ @ D��` @ @
>
> Texas Instruments X-Loader 1.4.4ss (Aug 16 2011 - 09:50:42)
> OMAP3530-GP ES3.1
> Board revision: 1
> Reading boot sector
> Loading u-boot.bin from mmc
>
>
> U-Boot 2010.12 (Aug 16 2011 - 09:52:23)
>
> OMAP3530-GP ES3.1, CPU-OPP2, L3-165MHz, Max CPU Clock 720 mHz
> Gumstix Overo board + LPDDR/NAND
> I2C:   ready
> DRAM:  512 MiB
> NAND:  512 MiB
> MMC:   OMAP SD/MMC: 0
> *** Warning - bad CRC, using default environment
>
> In:    serial
> Out:   serial
> Err:   serial
> Board revision: 1
> Direct connection on mmc2
> No EEPROM on expansion board
> Die ID #647600040000000004037f660700700a
> Net:   smc911x-0
> Hit any key to stop autoboot:  0
> reading boot.scr
>
> 64 bytes read
> � � tصb� $U
>                 @ @ @ D��` @ @
>
> Texas Instruments X-Loader 1.4.4ss (Aug 16 2011 - 09:50:42)
> OMAP3530-GP ES3.1
> Board revision: 1
> Reading boot sector
> Loading u-boot.bin from mmc
>
>
> U-Boot 2010.12 (Aug 16 2011 - 09:52:23)
>
> OMAP3530-GP ES3.1, CPU-OPP2, L3-165MHz, Max CPU Clock 720 mHz
> Gumstix Overo board + LPDDR/NAND
> I2C:   ready
> DRAM:  512 MiB
> NAND:  512 MiB
> MMC:   OMAP SD/MMC: 0
> � tصb� $U
>               @ @ @ D��` @ @
>
> Texas Instruments X-Loader 1.4.4ss (Aug 16 2011 - 09:50:42)
> OMAP3530-GP ES3.1
> Board revision: 1
> Reading boot sector
> Loading u-boot.bin from mmc
>
>
> U-Boot 2010.12 (Aug 16 2011 - 09:52:23)
>
> OMAP3530-GP ES3.1, CPU-OPP2, L3-165MHz, Max CPU Clock 720 mHz
> Gumstix Overo board + LPDDR/NAND
> I2C:   ready
> DRAM:  512 MiB
> NAND:  512 MiB
> MMC:   OMAP SD/MMC: 0
> *** Warning - bad CRC, using default environment
>
> In:    serial
> Out:   serial
> Err:   serial
> Board revision: 1
> Direct connection on mmc2
> No EEPROM on expansion board
> Die ID #647600040000000004037f660700700a
> Net:   smc911x-0
> Hit any key to stop autoboot:  0
> � tصb� $U
>               @ @ @ D��` @ @
>
> Texas Instruments X-Loader 1.4.4ss (Aug 16 2011 - 09:50:42)
> OMAP3530-GP ES3.1
> Board revision: 1
> Reading boot sector
> Loading u-boot.bin from mmc
>
>
> U-Boot 2010.12 (Aug 16 2011 - 09:52:23)
>
> OMAP3530-GP ES3.1, CPU-OPP2, L3-165MHz, Max CPU Clock 720 mHz
> Gumstix Overo board + LPDDR/NAND
> I2C:   ready
> DRAM:  512 MiB
> � tصb� $U
>               @ @ @ D��` @ @
>
> Texas Instruments X-Loader 1.4.4ss (Aug 16 2011 - 09:50:42)
> OMAP3530-GP ES3.1
> Board revision: 1
> Reading boot sector
> Loading u-boot.bin from mmc
>
>
> U-Boot 2010.12 (Aug 16 2011 - 09:52:23)
>
> OMAP3530-GP ES3.1, CPU-OPP2, L3-165MHz, Max CPU Clock 720 mHz
> Gumstix Overo board + LPDDR/NAND
> I2C:   ready
> DRAM:  512 MiB
> NAND:  512 MiB
> MMC:   OMAP SD/MMC: 0
> *** Warning - bad CRC, using default environment
>
> In:    serial
> Out:   serial
> Err:   serial
> Board revision: 1
> Direct connection on mmc2
> No EEPROM on expansion board
> Die ID #647600040000000004037f660700700a
> Net:   smc911x-0
> Hit any key to stop autoboot:  0
> reading boot.scr
> � tصb� $U
>               @ @ @ D��` @ @
>
> Texas Instruments X-Loader 1.4.4ss (Aug 16 2011 - 09:50:42)
> OMAP3530-GP ES3.1
> Board revision: 1
> Reading boot sector
> Loading u-boot.bin from mmc
>
>
> U-Boot 2010.12 (Aug 16 2011 - 09:52:23)
>
> OMAP3530-GP ES3.1, CPU-OPP2, L3-165MHz, Max CPU Clock 720 mHz
> Gumstix Overo board + LPDDR/NAND
> I2C:   ready
> DRAM:  512 MiB
> NAND:  512 MiB
> MMC:   OMAP SD/MMC: 0
> � tصb� $U
>               @ @ @ D��` @ @
>
> Texas Instruments X-Loader 1.4.4ss (Aug 16 2011 - 09:50:42)
> OMAP3530-GP ES3.1
> Board revision: 1
> Reading boot sector
> Loading u-boot.bin from mmc
>
>
> U-Boot 2010.12 (Aug 16 2011 - 09:52:23)
>
> OMAP3530-GP ES3.1, CPU-OPP2, L3-165MHz, Max CPU Clock 720 mHz
> Gumstix Overo board + LPDDR/NAND
> I2C:   ready
> DRAM:  512 MiB
> NAND:  512 MiB
> MMC:   OMAP SD/MMC: 0
> *** Warning - bad CRC, using default environment
>
> In:    serial
> Out:   serial
> Err:   serial
> Board revision: 1
> Direct connection on mmc2
> No EEPROM on expansion board
> Die ID #647600040000000004037f660700700a
> Net:   smc911x-0
> Hit any key to stop autoboot:  0
> � tصb� $U
>               @ @ @ D��` @ @
>
> Texas Instruments X-Loader 1.4.4ss (Aug 16 2011 - 09:50:42)
> OMAP3530-GP ES3.1
> Board revision: 1
> Reading boot sector
> Loading u-boot.bin from mmc
>
>
> U-Boot 2010.12 (Aug 16 2011 - 09:52:23)
>
> OMAP3530-GP ES3.1, CPU-OPP2, L3-165MHz, Max CPU Clock 720 mHz
> Gumstix Overo board + LPDDR/NAND
> I2C:   ready
> DRAM:  512 MiB
> NAND:  512 MiB
> MMC:   OMAP SD/MMC: 0
> *** Warning - bad CRC, using default environment
>
> In:    serial
> Out:   serial
> Err:   serial
> Board revision: 1
> Direct connection on mmc2
> No EEPROM on expansion board
> Die ID #647600040000000004037f660700700a
> Net:   smc911x-0
> Hit any key to stop autoboot:  0
> reading boo� � tصb� $U
>                           @ @ @ D��` @ @
>
> Texas Instruments X-Loader 1.4.4ss (Aug 16 2011 - 09:50:42)
> OMAP3530-GP ES3.1
> Board revision: 1
> Reading boot sector
> Loading u-boot.bin from mmc
>
>
> U-Boot 2010.12 (Aug 16 2011 - 09:52:23)
>
> OMAP3530-GP ES3.1, CPU-OPP2, L3-165MHz, Max CPU Clock 720 mHz
> Gumstix Overo board + LPDDR/NAND
> I2C:   ready
> DRAM:  512 MiB
> NAND:  512 MiB
> MMC:   OMAP SD/MMC: 0
> � tصb� $U
>               @ @ � D��` @ @
>
> Texas Instruments X-Loader 1.4.4ss (Aug 16 2011 - 09:50:42)
> OMAP3530-GP ES3.1
> Board revision: 1
> Reading boot sector
> Loading u-boot.bin from mmc
>
>
> U-Boot 2010.12 (Aug 16 2011 - 09:52:23)
>
> OMAP3530-GP ES3.1, CPU-OPP2, L3-165MHz, Max CPU Clock 720 mHz
> Gumstix Overo board + LPDDR/NAND
> I2C:   ready
> DRAM:  512 MiB
> NAND:  512 MiB
> MMC:   OMAP SD/MMC: 0
> *** Warning - bad CRC, using default environment
>
> In:    serial
> Out:   serial
> Err:   serial
> Board revision: 1
> Direct connection on mmc2
> No EEPROM on expansion board
> Die ID #647600040000000004037f660700700a
> Net:   smc911x-0
> Hit any key to stop autoboot:  0
> � tصb� $U
>               @ @ @ D��` @ @
>
> Texas Instruments X-Loader 1.4.4ss (Aug 16 2011 - 09:50:42)
> OMAP3530-GP ES3.1
> Board revision: 1
> Reading boot sector
> Loading u-boot.bin from mmc
>
>
> U-Boot 2010.12 (Aug 16 2011 - 09:52:23)
>
> OMAP3530-GP ES3.1, CPU-OPP2, L3-165MHz, Max CPU Clock 720 mHz
> Gumstix Overo board + LPDDR/NAND
> I2C:   ready
> DRAM:  512 MiB
> NAND:  512 MiB
> MMC:   OMAP SD/MMC: 0
> *** Warning - bad CRC, using default environment
>
> In:    serial
> Out:   serial
> Err:   serial
> Board revision: 1
> Direct connection on mmc2
> No EEPROM on expansion board
> Die ID #647600040000000004037f660700700a
> Net:   smc911x-0
> Hit any key to stop autoboot:  0
> 40W $U
>               @ @ @ D��` @ @
>
> Texas Instruments X-Loader 1.4.4ss (Aug 16 2011 - 09:50:42)
> OMAP3530-GP ES3.1
> Board revision: 1
> Reading boot sector
> Loading u-boot.bin from mmc
>
>
> U-Boot 2010.12 (Aug 16 2011 - 09:52:23)
>
> OMAP3530-GP ES3.1, CPU-OPP2, L3-165MHz, Max CPU Clock 720 mHz
> Gumstix Overo board + LPDDR/NAND
> I2C:   ready
> DRAM:  512 MiB
> NAND:  512 MiB
> MMC:   OMAP SD/MMC: 0
> � tصb� $U
>               @ @ @ D��` @ @
>
> Texas Instruments X-Loader 1.4.4ss (Aug 16 2011 - 09:50:42)
> OMAP3530-GP ES3.1
> Board revision: 1
> Reading boot sector
> Loading u-boot.bin from mmc
>
>
> U-Boot 2010.12 (Aug 16 2011 - 09:52:23)
>
> OMAP3530-GP ES3.1, CPU-OPP2, L3-165MHz, Max CPU Clock 720 mHz
> Gumstix Overo board + LPDDR/NAND
> I2C:   ready
> DRAM:  512 MiB
> NAND:  512 MiB
> MMC:   OMAP SD/MMC: 0
> *** Warning - bad CRC, using default environment
>
> In:    serial
> Out:   serial
> Err:   serial
> Board revision: 1
> Direct connection on mmc2
> No EEPROM on expansion board
> Die ID #647600040000000004037f660700700a
> Net:   smc911x-0
> Hit any key to stop autoboot:  0
> � tصb� $U
>               @ @ @ D��` @ @
>
> Texas Instruments X-Loader 1.4.4ss (Aug 16 2011 - 09:50:42)
> OMAP3530-GP ES3.1
> Board revision: 1
> Reading boot sector
> Loading u-boot.bin from mmc
>
>
> U-Boot 2010.12 (Aug 16 2011 - 09:52:23)
>
> OMAP3530-GP ES3.1, CPU-OPP2, L3-165MHz, Max CPU Clock 720 mHz
> Gumstix Overo board + LPDDR/NAND
> I2C:   ready
> DRAM:  512 MiB
> NAND:  512 MiB
> MMC:   OMAP SD/MMC: 0
> *** Warning - bad CRC, using default environment
>
> In:    serial
> Out:   serial
> Err:   serial
> Board revision: 1
> Direct connection on mmc2
> No EEPROM on expansion board
> Die ID #647600040000000004037f660700700a
> Net:   smc911x-0
> Hit any key to stop autoboot:  0
>
> #######################
> And when I break, using the print command I have:
>
> Overo # print
> baudrate=115200
> bootcmd=if mmc rescan ${mmcdev}; then if run loadbootscript; then run
> bootscript; else if run loaduimage; then run mmcboot; else run nandboot; fi;
> fi; else run nandboot; fi
> bootdelay=5
> bootscript=echo Running bootscript from mmc ...; source ${loadaddr}
> console=ttyS2,115200n8
> defaultdisplay=dvi
> dieid#=647600040000000004037f660700700a
> dvimode=1024x768MR-16@60
> ethact=smc911x-0
> loadaddr=0x82000000
> loadbootscript=fatload mmc ${mmcdev} ${loadaddr} boot.scr
> loaduimage=fatload mmc ${mmcdev} ${loadaddr} uImage
> mmcargs=setenv bootargs console=${console} mpurate=${mpurate} vram=${vram}
> omapfb.mode=dvi:${dvimode} omapdss.def_disp=${defaultdisplay}
> root=${mmcroot} rootfstype=${mmcrootfstype}
> mmcboot=echo Booting from mmc ...; run mmcargs; bootm ${loadaddr}
> mmcdev=0
> mmcroot=/dev/mmcblk0p2 rw
> mmcrootfstype=ext3 rootwait
> mpurate=720
> nandargs=setenv bootargs console=${console} mpurate=${mpurate} vram=${vram}
> omapfb.mode=dvi:${dvimode} omapdss.def_disp=${defaultdisplay}
> root=${nandroot} rootfstype=${nandrootfstype}
> nandboot=echo Booting from nand ...; run nandargs; nand read ${loadaddr}
> 280000 400000; bootm ${loadaddr}
> nandroot=/dev/mtdblock4 rw
> nandrootfstype=jffs2
> stderr=serial
> stdin=serial
> stdout=serial
> vram=12M
>
> Environment size: 1286/131068 bytes
>
> ###################################
>
> while booting from the NAND,  the mmc rescan in the boot environment becomes
> mmc init and the mpurate becomes 500.
>
> ######################
> Previously, I used to have an error saying unable to read boot.src but this
> was solved using
> https://github.com/scottellis/boot-scripts/blob/master/default-overo-boot.
>
> Please any help?
> My overo is booting indefinitely and I have been experiencing this for too
> long now; please help.
> I also read from your website that booting from the SD Card using your
> method can take long (~2h)! if so, does it behave like mine (looping back
> indefinitely) as shown above?
>
> Thank you in advance,
> Gutembert.
>
> --
> View this message in context: http://gumstix.8.n6.nabble.com/new-overo-air-does-not-come-up-while-sd-card-inserted-tp611882p4898675.html
> Sent from the Gumstix mailing list archive at Nabble.com.

>
> ------------------------------------------------------------------------------
> For Developers, A Lot Can Happen In A Second.
> Boundary is the first to Know...and Tell You.
> Monitor Your Applications in Ultra-Fine Resolution. Try it FREE!
> http://p.sf.net/sfu/Boundary-d2dvs2
> _______________________________________________
> gumstix-users mailing list
> [hidden email]
> https://lists.sourceforge.net/lists/listinfo/gumstix-users
You should not get looping at all. When they say it will take a long
time to boot it just looks like it has hung there for a bit.

Did you try booting with a cleared environment after re-doing the
sdcard? You can get the can not find boot.scr warning and have it still
boot, just means it will fall back to the default config. Try booting
with just the default config.

Also did you copy the MLO first after the sdcard was created? Not sure
if that script copies your files for you or not. MLO has to be the first
thing copied on to the FAT partition of the sdcard.

My guess is the u-boot.bin is not right, as in a bad copy or bad
build/download. As it seems to hang on that spot.

HTH

------------------------------------------------------------------------------
For Developers, A Lot Can Happen In A Second.
Boundary is the first to Know...and Tell You.
Monitor Your Applications in Ultra-Fine Resolution. Try it FREE!
http://p.sf.net/sfu/Boundary-d2dvs2
_______________________________________________
gumstix-users mailing list
[hidden email]
https://lists.sourceforge.net/lists/listinfo/gumstix-users



If you reply to this email, your message will be added to the discussion below:
http://gumstix.8.n6.nabble.com/new-overo-air-does-not-come-up-while-sd-card-inserted-tp611882p4898721.html
To unsubscribe from new overo air does not come up while sd card inserted, click here.
NAML



View this message in context: Re: new overo air does not come up while sd card inserted

Sent from the Gumstix mailing list archive at Nabble.com.


------------------------------------------------------------------------------
For Developers, A Lot Can Happen In A Second.
Boundary is the first to Know...and Tell You.
Monitor Your Applications in Ultra-Fine Resolution. Try it FREE!
http://p.sf.net/sfu/Boundary-d2dvs2


_______________________________________________
gumstix-users mailing list
[hidden email]
https://lists.sourceforge.net/lists/listinfo/gumstix-users


------------------------------------------------------------------------------
For Developers, A Lot Can Happen In A Second.
Boundary is the first to Know...and Tell You.
Monitor Your Applications in Ultra-Fine Resolution. Try it FREE!
http://p.sf.net/sfu/Boundary-d2dvs2
_______________________________________________
gumstix-users mailing list
[hidden email]
https://lists.sourceforge.net/lists/listinfo/gumstix-users



If you reply to this email, your message will be added to the discussion below:
http://gumstix.8.n6.nabble.com/new-overo-air-does-not-come-up-while-sd-card-inserted-tp611882p4899609.html
To unsubscribe from new overo air does not come up while sd card inserted, click here.
NAML



View this message in context: Re: new overo air does not come up while sd card inserted
Sent from the Gumstix mailing list archive at Nabble.com.


------------------------------------------------------------------------------
For Developers, A Lot Can Happen In A Second.
Boundary is the first to Know...and Tell You.
Monitor Your Applications in Ultra-Fine Resolution. Try it FREE!
http://p.sf.net/sfu/Boundary-d2dvs2


_______________________________________________
gumstix-users mailing list
[hidden email]
https://lists.sourceforge.net/lists/listinfo/gumstix-users


------------------------------------------------------------------------------
For Developers, A Lot Can Happen In A Second.
Boundary is the first to Know...and Tell You.
Monitor Your Applications in Ultra-Fine Resolution. Try it FREE!
http://p.sf.net/sfu/Boundary-d2dvs2
_______________________________________________
gumstix-users mailing list
[hidden email]
https://lists.sourceforge.net/lists/listinfo/gumstix-users



If you reply to this email, your message will be added to the discussion below:
http://gumstix.8.n6.nabble.com/new-overo-air-does-not-come-up-while-sd-card-inserted-tp611882p4899843.html
To unsubscribe from new overo air does not come up while sd card inserted, click here.
NAML




View this message in context: Re: new overo air does not come up while sd card inserted
Sent from the Gumstix mailing list archive at Nabble.com.