Great.  I knew it would be something like that.  Do you (or anyone for that matter) have any idea how to set up a stream from the caspa. I see it identified during boot, yet if I try gst-launch v4l2src, it returns with /dev/video0 is not a capture device. So I tried gst-launch v4l2src device=/dev/video1 up to video 6, and no luck.




From: Nick Wernicke []
Sent: Sunday, November 11, 2012 2:41 PM
To: General mailing list for gumstix users.
Subject: Re: [Gumstix-users] adding support for tvp514x


Nevermind... found it.  I had to install libncurses5-dev.

On Sun, Nov 11, 2012 at 2:25 PM, Nick Wernicke <> wrote:

I haven't done menuconfig in yocto before.  When I run 


bitbake -c menuconfig linux_sakoman


it just opens a window for a brief second, then closes the window and says task do_menuconfig: Succeeded.  Is there something else I need to do in the environment or something? I'm using Ubuntu 12.10.


On Sat, Nov 10, 2012 at 8:20 AM, rklosinski <> wrote:

correction.... I assume I needed 3.2 since my previous attempt generated it.
Totally scratching the initial jumpnow method and following the one
published on sleepyrobot yielded working gstreamer core.

The bitbake -c menuconfig linux-sakoman (then followed by bitbake
linux-sakoman) allowed me to get the tvp514x and tvp5150 drivers in the
modules file which were copied onto the rootfs. I've yet to test these

So far, streaming from videotestsrc works (gst-launch videotestsrc !
video/x-raw-yuv,width=320,height=240 ! TIVidenc1 codecName=h264enc
engineName=codecServer ! rtph264pay pt=96 ! udpsink host=

Although the caspa was connected, and was identifed during boot. I've yet to
figure out how to stream from it. Ive tried:
gst-launch -v v4l2src ! video/x-raw-yuv,width=320,height=240 ! TIVidenc1
codecName=h264enc engineName=codecServer ! rtph264pay pt=96 ! udpsink
host= port=4000

and it failed stating /dev/video0 is not a capture device.

Other things that needed fixing:
I needed to do the following for uboot:
...interrupt the boot
nand erase 240000 20000
...interrupt the boot
setenv mmcargs setenv bootargs console=${console} mpurate=${mpurate}
vram=${vram} omapfb.mode=dvi:${dvimode} omapfb.debug=y
omapdss.def_disp=${defaultdisplay} mem=96M@0x80000000 mem=128M@0x88000000
root=${mmcroot} rootfstype=${mmcrootfstype}

setenv bootsdelay 1 (my personal pref)
run mmcargs

Im sure there is a more elegant way of setting the memory region (I think
jumpnow had a better way) but this worked for now.

Im still trying to get the caspa work....

View this message in context:

Sent from the Gumstix mailing list archive at

Everyone hates slow websites. So do we.
Make your web apps faster with AppDynamics
Download AppDynamics Lite for free today:
gumstix-users mailing list