Hi Jocc,


I also started working with OE and my 4M 200MHz gumstix.  The problem is further exacerbated by the fact that all the OE releases require U-Boot 1.2.0 which creates a 1MB kernel space at the in memory leaving less than 3M for the root file system.  I worked for a couple of days taking things out of gumstix-minimal-image and got as small as 3.4M which was still too large.


Ultimately, I came to the conclusion that I would need to go to an external SD/MMC/CF card to store the root file system and my current goal was a form factor without such a daughter card.  I opted for a new 16M ‘stix, instead.


Sorry my experience wasn’t more encouraging.  It is possible, however, that I just didn’t remove enough modules to get the file system reduced and you can accomplish what I couldn’t in your application.  I went back to buildroot and U-Boot 1.1.4 (username: root – password: root) for work on the 4MB system.




From: gumstix-users-bounces@lists.sourceforge.net [mailto:gumstix-users-bounces@lists.sourceforge.net] On Behalf Of József Lénárt
Sent: Tuesday, April 22, 2008 4:05 AM
To: gumstix-users@lists.sourceforge.net
Subject: [Gumstix-users] OpenEmbedded on Basix 200



I have a problem with the OpenEmbedded. I'm working with an old Basix 200 with 4M flash and the OpenEmbedded gumstix-basic-image is about 8M. What can i do ? I've tried the good old buildroot, but the svn requires a password (authentication realm...). I've missed something ?


P.S.: openembedded.org is down/they are reinstalling the server ?

Jozsef Lenart
Phd Student, Departmental Engineer
Robert Bosch Department of Mechatronics, Faculty of Mechanical Engineering and Informatics, University of Miskolc, Hungary