I have a similar problem on two overo fire+summit board with the default image. The RX of the overo works fine and the TX doesn't.
Is there any trick to get it to work?

I have tried with the sparkfun logic converter plugged to a usb serial ftdi and the overo receives characters but it does not transmit.
I have also tried making a loop (RX plug to TX on the overo) and I don't get the characters on screen with minicom.


2011/6/16 tomason <tomason23@126.com>
Hello all,
I use the summit(and overo air) connect to avr micro-controller by ttyS0s, the logic level of ttyS0 on avr has changed to 1.8V. When I connected them together, 
run my program to send message from overo air to avr,the voltage level of ttyS0's Tx changed to 0V, and the Rx of it can't receive any signal from any other 
device's Tx because of the voltage level can't reach 1.8V. Is there any wrong operation for the settings of serials, how to make the voltage level back to normal?
Any help would be great appreciate.
Best regards

EditLive Enterprise is the world's most technically advanced content
authoring tool. Experience the power of Track Changes, Inline Image
Editing and ensure content is compliant with Accessibility Checking.
gumstix-users mailing list

Linus Casassa
Estudiante Ingeniería Civil Electrónica
Universidad Técnica Federico Santa María
Fono: 56-9-97776941