The script seems to work for me.

I don't know that much about linux internals, but I suppose it makes quite a bit of sense that iptables will also require kernel modules. My mistake.

I followed the directions Dave posted and had no hanging on boot. However, when I tried merely to list the iptables, it complained about unknown symbols. I tried to insert the modules, and had no luck with that either. So I changed everything (that would accept it) to "yes" rather than "module", and now /lib/modules/2.6.34/ doesn't appear to have the modules anymore, whereas they were previously in there under a net/ path. I still get the "do you need to insmod?" error on running iptables, but not the unknown symbols.

Like I said, I really don't know linux internals. I may have done something stupid in here.

On Mon, Apr 4, 2011 at 12:39 PM, pjb304 <pjb08r@ecs.soton.ac.uk> wrote:

I've been putting it off as long as possible as well ;)

Thanks for the reply.  I assume you mean to add it into the
"ANGSTROM_EXTRA_INSTALL" field as I couldn't find a "tools" field in the bb
file.  That does get iptables running but without the kernel module.
Unfortunately the iptables command I need to run "iptables -A OUTPUT -t
mangle -ptcp --dport 22 -j TOS --set-tos 0x00" (to overcome the problem
linked to in  https://bugzilla.redhat.com/show_bug.cgi?id=487423 here )
requires the kernel module to be installed, as without it it gives the
following error message "iptables v1.4.9.1: can't initialize iptables table
`mangle': iptables who? (do you need to insmod?)"

Any further ideas very gratefully received.
Philip
---
Philip Basford
PhD Student
Intelligence, Agents and Multimedia Group
School of Electronics and Computer Science
University of Southampton
Highfield
Southampton
SO17 1BJ
UK
+44 (0)23 8059 4583



Joseph Hickman wrote:
>
> I know I'll eventually be needing iptables in my build, but I've been
> putting off looking into it. Thanks for the reminder.
>
> I was able to get it in by simply adding "iptables" into the list of tools
> in the image's recipe.
> (overo-oe/org.openembedded.dev/recipes/images/<imagename>.bb) I've
> confirmed
> that I can boot with this image and use iptables. FYI, I'm working off the
> minimal image Scott Ellis has referenced in the past.
>

--
View this message in context: http://old.nabble.com/iptables-on-Overo-tp29114215p31316180.html
Sent from the Gumstix mailing list archive at Nabble.com.


------------------------------------------------------------------------------
Create and publish websites with WebMatrix
Use the most popular FREE web apps or write code yourself;
WebMatrix provides all the features you need to develop and
publish your website. http://p.sf.net/sfu/ms-webmatrix-sf
_______________________________________________
gumstix-users mailing list
gumstix-users@lists.sourceforge.net
https://lists.sourceforge.net/lists/listinfo/gumstix-users