I've tried following your outlined steps but still keep have issues. I ran the merge tool and tried to merge the correction to the receipt, this is my first time using a diff tools like this but thing i figured it out. Then I ran  git commit since I couldnt cherry pick without doing so. Lastly I tried running bitbake prismstumbler but get an error about a missing file libgps. I tried running bitbake libgps but no bitbake could be found providing libgps. I am guessing i'm messing up the receipt somehow since I had three files to merge, or missing something I should have.Maybe if you could attach you prismstumbler receipt that could help. Attached is what I am doing the the messages I am get.

uav@uav-laptop:~/verdex-oe/$ git mergetoolmerge tool candidates: meld opendiff kdiff3 tkdiff xxdiff tortoisemerge gvimdiff diffuse ecmerge p4merge araxis emerge vimdiff
Merging the files: recipes/prismstumbler/

Normal merge conflict for 'recipes/prismstumbler/':
  {local}: modified
  {remote}: modified
Hit return to start merge resolution tool (meld):
uav@uav-laptop:~/verdex-oe/$ git commit
[verdex 8050d2b] Add patch to replace gps_query call
 Committer: UAV <uav@uav-laptop.(none)>
Your name and email address were configured automatically based
on your username and hostname. Please check that they are accurate.
You can suppress this message by setting them explicitly:

    git config --global "Your Name"
    git config --global

If the identity used for this commit is wrong, you can fix it with:

    git commit --amend --author='Your Name <>'

 2 files changed, 26 insertions(+), 7 deletions(-)
 create mode 100644 recipes/prismstumbler/prismstumbler-0.7.3+0.7.4pre1/replace-gps_query.patch
uav@uav-laptop:~/verdex-oe/$ git cherry-pick e43cc49ace4692287a4e31e72079727cef329b6b
warning: too many files (created: 2873 deleted: 3560), skipping inexact rename detection
Finished one cherry-pick.
# On branch verdex
# Your branch is ahead of 'origin/verdex' by 1 commit.
# Untracked files:
#   (use "git add <file>..." to include in what will be committed)
#    recipes/prismstumbler/
nothing added to commit but untracked files present (use "git add" to track)
uav@uav-laptop:~/verdex-oe/$ bitbake prismstumbler
NOTE: Handling BitBake files: / (8361/8361) [100 %]
NOTE: Parsing finished. 7580 cached, 442 parsed, 339 skipped, 1 masked.
NOTE: Resolving any missing task queue dependencies
NOTE: Preparing runqueue
NOTE: Executing runqueue
NOTE: Running task 1794 of 2528 (ID: 7, /home/uav/verdex-oe/, do_configure)
ERROR: function do_configure failed
ERROR: log data follows (/home/uav/verdex-oe/tmp/work/armv5te-angstrom-linux-gnueabi/prismstumbler-0.7.3+0.7.4pre1-r6/temp/log.do_configure.5548)
| automake (GNU automake) 1.11.1
| Copyright (C) 2009 Free Software Foundation, Inc.
| License GPLv2+: GNU GPL version 2 or later <>
| This is free software: you are free to change and redistribute it.
| There is NO WARRANTY, to the extent permitted by law.
| Written by Tom Tromey <>
|        and Alexandre Duret-Lutz <>.
| AUTOV is 1.11
| NOTE: Executing autoreconf --verbose --install --force --exclude=autopoint -I/home/uav/verdex-oe/tmp/staging/armv5te-angstrom-linux-gnueabi/usr/share/aclocal-1.11 -I /home/uav/verdex-oe/tmp/staging/armv5te-angstrom-linux-gnueabi/usr/share/aclocal
| autoreconf: Entering directory `.'
| autoreconf: not using Gettext
| autoreconf: running: aclocal -I /home/uav/verdex-oe/tmp/staging/armv5te-angstrom-linux-gnueabi/usr/share/aclocal-1.11 -I /home/uav/verdex-oe/tmp/staging/armv5te-angstrom-linux-gnueabi/usr/share/aclocal -I /home/uav/verdex-oe/tmp/staging/armv5te-angstrom-linux-gnueabi/usr/share/aclocal-1.11 -I /home/uav/verdex-oe/tmp/staging/armv5te-angstrom-linux-gnueabi/usr/share/aclocal --force
| /home/uav/verdex-oe/tmp/staging/armv5te-angstrom-linux-gnueabi/usr/share/aclocal/xmms.m4:17: warning: underquoted definition of XMMS_TEST_VERSION
| /home/uav/verdex-oe/tmp/staging/armv5te-angstrom-linux-gnueabi/usr/share/aclocal/xmms.m4:17:   run info '(automake)Extending aclocal'
| /home/uav/verdex-oe/tmp/staging/armv5te-angstrom-linux-gnueabi/usr/share/aclocal/xmms.m4:17:   or see
| autoreconf: tracing
| autoreconf: not using Libtool
| autoreconf: running: /home/uav/verdex-oe/tmp/staging/i686-linux/usr/bin/autoconf --include=/home/uav/verdex-oe/tmp/staging/armv5te-angstrom-linux-gnueabi/usr/share/aclocal-1.11 --include=/home/uav/verdex-oe/tmp/staging/armv5te-angstrom-linux-gnueabi/usr/share/aclocal --force --warnings=cross
| autoreconf: running: /home/uav/verdex-oe/tmp/staging/i686-linux/usr/bin/autoheader --include=/home/uav/verdex-oe/tmp/staging/armv5te-angstrom-linux-gnueabi/usr/share/aclocal-1.11 --include=/home/uav/verdex-oe/tmp/staging/armv5te-angstrom-linux-gnueabi/usr/share/aclocal --force --warnings=cross
| autoreconf: running: automake --foreign --add-missing --copy --force-missing --warnings=cross
| automake: unknown warning category `cross'
| autoreconf: running: gnu-configize
| autoreconf: Leaving directory `.'
| NOTE: Running /home/uav/verdex-oe/tmp/work/armv5te-angstrom-linux-gnueabi/prismstumbler-0.7.3+0.7.4pre1-r6/prismstumbler-0.7.4pre1/configure             --build=i686-linux             --host=arm-angstrom-linux-gnueabi             --target=arm-angstrom-linux-gnueabi             --prefix=/usr             --exec_prefix=/usr             --bindir=/usr/bin             --sbindir=/usr/sbin             --libexecdir=/usr/libexec             --datadir=/usr/share             --sysconfdir=/etc             --sharedstatedir=/com             --localstatedir=/var             --libdir=/usr/lib         --includedir=/usr/include             --oldincludedir=/usr/include         --infodir=/usr/share/info             --mandir=/usr/share/man         --x-includes=/home/uav/verdex-oe/tmp/staging/armv5te-angstrom-linux-gnueabi/usr/include/X11         --x-libraries=/home/uav/verdex-oe/tmp/staging/armv5te-angstrom-linux-gnueabi/usr/lib         --with-libpcap=/home/uav/verdex-oe/tmp/staging/armv5te-angstrom-linux-gnueabi/usr         --with-sqlite-includes=/home/uav/verdex-oe/tmp/staging/armv5te-angstrom-linux-gnueabi/usr/include     --with-sqlite-libs=/home/uav/verdex-oe/tmp/staging/armv5te-angstrom-linux-gnueabi/usr/lib         --without-athena --enable-dbus                 --with-libiw=/home/uav/verdex-oe/tmp/staging/armv5te-angstrom-linux-gnueabi/usr             ...
| configure: WARNING: unrecognized options: --with-sqlite-includes, --with-sqlite-libs, --without-athena
| configure: loading site script /home/uav/verdex-oe/
| configure: loading site script /home/uav/verdex-oe/
| configure: loading site script /home/uav/verdex-oe/
| configure: loading site script /home/uav/verdex-oe/
| configure: loading site script /home/uav/verdex-oe/
| configure: loading site script /home/uav/verdex-oe/
| configure: loading site script /home/uav/verdex-oe/
| checking for a BSD-compatible install... /home/uav/verdex-oe/tmp/staging/i686-linux/usr/bin/install -c
| checking whether build environment is sane... yes
| checking for arm-angstrom-linux-gnueabi-strip... arm-angstrom-linux-gnueabi-strip
| checking for a thread-safe mkdir -p... /home/uav/verdex-oe/tmp/staging/i686-linux/usr/bin/mkdir -p
| checking for gawk... gawk
| checking whether make sets $(MAKE)... yes
| checking for arm-angstrom-linux-gnueabi-gcc... arm-angstrom-linux-gnueabi-gcc -march=armv5te -mtune=xscale -mthumb-interwork -mno-thumb
| checking whether the C compiler works... yes
| checking for C compiler default output file name... a.out
| checking for suffix of executables...
| checking whether we are cross compiling... yes
| checking for suffix of object files... o
| checking whether we are using the GNU C compiler... yes
| checking whether arm-angstrom-linux-gnueabi-gcc -march=armv5te -mtune=xscale -mthumb-interwork -mno-thumb accepts -g... yes
| checking for arm-angstrom-linux-gnueabi-gcc -march=armv5te -mtune=xscale -mthumb-interwork -mno-thumb option to accept ISO C89... none needed
| checking for style of include used by make... GNU
| checking dependency style of arm-angstrom-linux-gnueabi-gcc -march=armv5te -mtune=xscale -mthumb-interwork -mno-thumb... gcc3
| checking how to run the C preprocessor... arm-angstrom-linux-gnueabi-gcc -E
| checking for grep that handles long lines and -e... /bin/grep
| checking for egrep... /bin/grep -E
| checking for ANSI C header files... yes
| checking for sys/types.h... yes
| checking for sys/stat.h... yes
| checking for stdlib.h... yes
| checking for string.h... yes
| checking for memory.h... yes
| checking for strings.h... yes
| checking for inttypes.h... yes
| checking for stdint.h... yes
| checking for unistd.h... yes
| checking for strings.h... (cached) yes
| checking for unistd.h... (cached) yes
| checking for string.h... (cached) yes
| checking sys/socket.h usability... yes
| checking sys/socket.h presence... yes
| checking for sys/socket.h... yes
| checking for sys/types.h... (cached) yes
| checking sys/un.h usability... yes
| checking sys/un.h presence... yes
| checking for sys/un.h... yes
| checking poll.h usability... yes
| checking poll.h presence... yes
| checking for poll.h... yes
| checking features.h usability... yes
| checking features.h presence... yes
| checking for features.h... yes
| checking for stdlib.h... (cached) yes
| checking stdio.h usability... yes
| checking stdio.h presence... yes
| checking for stdio.h... yes
| checking fcntl.h usability... yes
| checking fcntl.h presence... yes
| checking for fcntl.h... yes
| checking for sys/stat.h... (cached) yes
| checking sys/file.h usability... yes
| checking sys/file.h presence... yes
| checking for sys/file.h... yes
| checking errno.h usability... yes
| checking errno.h presence... yes
| checking for errno.h... yes
| checking time.h usability... yes
| checking time.h presence... yes
| checking for time.h... yes
| checking sys/ioctl.h usability... yes
| checking sys/ioctl.h presence... yes
| checking for sys/ioctl.h... yes
| checking for sys/socket.h... (cached) yes
| checking linux/types.h usability... yes
| checking linux/types.h presence... yes
| checking for linux/types.h... yes
| checking linux/socket.h usability... yes
| checking linux/socket.h presence... yes
| checking for linux/socket.h... yes
| checking whether to support shared library linked as release mode or not... no
| checking for arm-angstrom-linux-gnueabi-pkg-config... no
| checking for pkg-config... /home/uav/verdex-oe/tmp/staging/i686-linux/usr/bin/pkg-config
| configure: WARNING: using cross tools not prefixed with host triplet
| checking pkg-config is at least version 0.9.0... yes
| checking for SQLITE... yes
| checking for GLIB... yes
| checking for GTK... yes
| checking if dbus support is requested... no
| checking for libpcap... /home/uav/verdex-oe/tmp/staging/armv5te-angstrom-linux-gnueabi/usr
| checking for libgps... no
| configure: error: libgps not found
| FATAL: oe_runconf failed
NOTE: Task failed: /home/uav/verdex-oe/tmp/work/armv5te-angstrom-linux-gnueabi/prismstumbler-0.7.3+0.7.4pre1-r6/temp/log.do_configure.5548
ERROR: TaskFailed event exception, aborting
ERROR: Build of /home/uav/verdex-oe/ do_configure failed
ERROR: Task 7 (/home/uav/verdex-oe/, do_configure) failed
NOTE: Tasks Summary: Attempted 1793 tasks of which 1793 didn't need to be rerun and 1 failed.
ERROR: '/home/uav/verdex-oe/' failed

Thanks in advance,


On Tue, Jun 28, 2011 at 12:15 AM, Ash Charles <> wrote:
Hi Casey,

On Mon, Jun 27, 2011 at 5:48 PM, Casey St.Fleur <> wrote:
> uav@uav-laptop:~/verdex-oe/$ git cherry-pick
> e43cc49ace4692287a4e31e72079727cef329b6b
> warning: too many files (created: 2872 deleted: 3560), skipping inexact
> rename detection
> Automatic cherry-pick failed.  After resolving the conflicts,
> mark the corrected paths with 'git add <paths>' or 'git rm <paths>'
> and commit the result with:
>         git commit -c e43cc49ace4692287a4e31e72079727cef329b6b
Git is pretty good at handling merge conflicts---it just takes a
little coaxing once in a while.  I tried this merge and just had to
fix one file.  Specifically,
$ sudo apt-get install meld (this is a good diff tool)
$ git mergetool (and then follow the prompts to resolve the conflict.
I just took all the fixes from the 'Remote' cherry-pick
$ bitbake prismstumbler


All of the data generated in your IT infrastructure is seriously valuable.
Why? It contains a definitive record of application performance, security
threats, fraudulent activity, and more. Splunk takes this data and makes
sense of it. IT sense. And common sense.
gumstix-users mailing list