I'm using Linux 2.6.36, Gnome build (April build), on my Gumstix Summit-Fire combo.

When I run these commands:

#nmcli con down id CSN-l
ifconfig wlan0
iwconfig wlan0 mode ad-hoc essid gumstix-network
nmcli con up id gumnet

where, gumnet is configured to be an Ad-Hoc network. But when I run
the last command after successfully running all other commands, i get
the output as shown below:

root@omap3-multi:~# nmcli con up id gumnet
Active connection state: activating
Active connection path: /org/freedesktop/NetworkManager/ActiveConnection/7

** (process:1231): WARNING **: _nm_object_get_property: Error getting
'State' for /org/freedesktop/NetworkManager/ActiveConnection/7: (19)
Method "Get" with signature "ss" on interface
"org.freedesktop.DBus.Properties" doesn't exist

state: unknown
Error: Connection activation failed.

So basically I'm not able to get the wifi ad-hoc mode up and running. Am I missing any commands/configuration..?
I have also configured the DHCP server and have started it.
I have also tried with the latest Gnome build, which also gives the same errors.

Has anybody encountered a similar problem.....??
I want to set up a local Ad-Hoc network on the gumstix which will
serve other systems and mobiles around.

Sudhangathan BS
Ph:(+91) 9731-905-205