I tried

gst-launch -v udpsrc port=10000 caps = "application/x-rtp, media=(string)video, clock-rate=(int)90000, encoding-name=(string)H264, sprop-parameter-sets=(string)\"Z0KAHukBQHpCAAAH0AAB1MAIAA\\=\\=\\,aM48gAA\\=\", payload=(int)96, ssrc=(uint)1541839946, clock-base=(uint)4264424652, seqnum-base=(uint)30274" ! rtph264depay ! ffdec_h264 ! ffmpegcolorspace ! xvimagesink sync=false

and got

WARNING: erroneous pipeline: could not set property "caps" in element "udpsrc0" to "application/x-rtp, media=(string)video, clock-rate=(int)90000, encoding-name=(string)H264, sprop-parameter-sets=(string)"Z0KAHukBQHpCAAAH0AAB1MAIAA==,aM48gAA=", payload=(int)96, ssrc=(uint)1541839946, clock-base=(uint)4264424652, seqnum-base=(uint)30274"

If i shortened caps to ""application/x-rtp, media=(string)video, clock-rate=(int)90000, encoding-name=(string)H264" it works just like pure UDP, and I have to start the client before the server else nothing will show up.

On Tue, Mar 29, 2011 at 1:41 PM, neno <neno@nenotechnology.com> wrote:

I seem to remember having the same issue, until I added rtp to the stream.
Now it works both ways.

Steven-132 wrote:
> Thanks that seem to get the udp streaming working.  Though I still can't
> save to a file for some reason.
> Also, it is possible to start the client (udpsrc) after the server?  If I
> do
> that gst-launch just sit there and doens't display a window.

View this message in context: http://old.nabble.com/gstreamer-on-gumstix-tp31262571p31269926.html
Sent from the Gumstix mailing list archive at Nabble.com.

Enable your software for Intel(R) Active Management Technology to meet the
growing manageability and security demands of your customers. Businesses
are taking advantage of Intel(R) vPro (TM) technology - will your software
be a part of the solution? Download the Intel(R) Manageability Checker
today! http://p.sf.net/sfu/intel-dev2devmar
gumstix-users mailing list