Thank you for your help.  I believe I am using Neil's recipe to build the uImage and modules with bitbake linux-omap3-2.6.36.  However, when I build this myself and load it on to my gumstix, no modules are loaded on startup. When I run lsmod, it is blank.  When I run lsmod using your prebuilt images and modules, I get:

Module                  Size  Used by
libertas_sdio          14461  0
cp210x                 10652  0
libertas               89181  1 libertas_sdio
ftdi_sio               27591  0
lib80211                5171  1 libertas
ads7846                 8867  0
usbserial              30623  2 cp210x,ftdi_sio
ipv6                  222207  14

I would love to understand the error because in the future I would like to be able to customize the kernel myself.

Also, thank you for directing me to your GNOME image feed.  This will do the trick as I puzzle over my build problems.


On Thu, Feb 24, 2011 at 8:53 AM, Steve Sakoman <sakoman@gmail.com> wrote:
On Thu, Feb 24, 2011 at 5:31 AM, Adam Stambler <adasta@gmail.com> wrote:
> Hello Folks,
> What kernel defconfig settings are chosen for the sakoman prebuilt overo
> kernel images?

They are built using the OE linux-omap3 recipes in the Overo branch.

> I have had great success with my gumstix using sakoman's prebuilt images.
> However, now I want to use a newer kernel version which sakoman does not
> provide, linux-ompa3-2.6.36.

IIRC, the most recent pre-built image set has a 2.6.36 kernel.

Neil has taken over the OE repo and pre-built image generation.
Perhaps he can comment on a target date for availability of builds
from the new build server.

In the meantime, if you want a pre-built image that uses 2.6.36 you
could use my GNOME image:


> I have built it using bitbake and installed it
> and its modules onto my Overo Fire.  Unlike the prebuilt image, it does not
> load the libertas driver or even create the ttyUSBs for the usb to serial
> converters attached to my gumstix.
> I am using the latest org.openembedded.dev git repo and I am tracking the
> overo branch.  To build the kernel I am running bitbake
> linux-omap3-2.6.36.   Is there another branch or repo with sakoman's
> standard image settings enabled?

You might want to try pulling again, since Neil has added a 2.6.36
recipe to the Overo branch:



Free Software Download: Index, Search & Analyze Logs and other IT data in
Real-Time with Splunk. Collect, index and harness all the fast moving IT data
generated by your applications, servers and devices whether physical, virtual
or in the cloud. Deliver compliance at lower cost and gain new business
insights. http://p.sf.net/sfu/splunk-dev2dev
gumstix-users mailing list