Hi all,

I am a college student developer and I doing a project that requires the DSP on the overo fire.  After three days of work I finally have open embedded up (and can interface with board via ethernet), and after following the pixhawk tutorial have ti-dsplink-module and ti-codec-engine compile but not depolyed.  the final piece to this prize before development is getting the cmem-module to compile.  Everytime I use the bitbake ti-cmem-module command (from the normal command terminal user or from the oe directory in the source build/profile overo) I get these errors:

OE:overo laptop1@laptop1-laptop:~/overo-oe$ bitbake ti-cmem-module
NOTE: Handling BitBake files: | (8404/8404) [100 %]
NOTE: Parsing finished. 7626 cached, 460 parsed, 318 skipped, 1 masked.
ERROR: Nothing PROVIDES 'ti-cmem-module'


or

ERROR: no such table: BB_URI_LOCALCOUNT while parsing /home/laptop1/overo-oe/org.openembedded.dev/recipes/linux/linux-openmoko-devel_git.bb
NOTE: Handling BitBake files: - (8395/8395) [100 %]
NOTE: Parsing finished. 0 cached, 7833 parsed, 293 skipped, 1 masked.
ERROR: Parsing errors found, exiting...

I am completely out of ideas and will take any advice I can get.  The reason I need this is to get the DSPlink toolchain working so I can compile my own code.  Write now when I try to compile one of the samples I get this error:

/home/laptop1/cross/armv7a/bin/../lib/gcc/arm-angstrom-linux-gnueabi/4.3.3/../../../../arm-angstrom-linux-gnueabi/bin/ld: cannot find cmem.o
collect2: ld returned 1 exit status
make[2]: *** [messagegpp.deb] Error 1
make[1]: *** [trgdeb] Error 2
make: *** [message.trgdeb] Error 2


Thanks in advance!

-Jim