I am trying to get eth0 set up on my Gumstix overo.

I thought I had this correct as I have been experimenting with both DHCP and static assignment of the IP Address, Netmask, Network and Gateway. I was using DHCP when I found that I could not get my application to discover the Gumstix which is issuing a broadcast to find my client.

On investigation I found that the broadcast address had been set to, when I manually set this to I could detect the Gumstix broadcast, but now Gumstix could not access the web from my application.

I have one application running on Gumstix and another running on a PC on the same network.

The only way that I can get both the broadcast and web access working is when I assign everything static from within the /etc/network/interfaces file.

Has anyone experience this kind of problem and if so what was the solution.

I have tried adding to the resolve.conf file, but no combination of set up works for me.

I am running kernel 2.6.29 and have also tried 30, neither work.

The DHCP server happily supplies addresses to other devices on the network it is only Gumstix which gets the wrong settings.

Thanks in advance for any help provided.