Hi.
 
I have a problem with my Gumstix Verdex.
Recently I bougth a microSD card, because I have the intention to install the MySQL server inside.
 
I try to do the MySQL instalation in 2 diferent ways.
(I've formatted the microSD card with an ext2).
 
The First way:
 
First I try to install directly throw gumstix, using this commad:
ipkg -d mmc install mysql
Then I've linked the new installation packages to the root file system, using:
ipkg-link mount /media/card
Finaly I've tried to execute: mysql --version and the system return the MySQL version.
 

But when I've tried to do mysql -u root -p the system showed me the next error message:

Can't connect to MySql database, can't find mysql.sock

When I try to lunch mysql for the first time, mysql.sock is not in the "tmp" directory. But if I reboot the gumstix the file (mysql.sock) appears in "tmp" directory, 

but still gives the same error.

The Second way:

I Compiled the MySQL pakages with Bitbake on my PC. Then I send the pakages to microSD card and. I do continued the same process like in the First Way, baut the error is the same.

 

I try to do all of the "normal" solutions, but I failed to solve the problem

I don't know what else to do.

 

Please can anybody help me.

=====================================

FATRONIK

Asier Berasategui

Departamento CTICs // CTICs Deparment

Teléfono: 943 01 55 00 (Ext:335)