Hi,

Thanks for the suggestion.  I tried the boot in several ways without the "ro 3" as you suggest and it still doesn't do the right thing, unfortunately.  The kernel_execve is invoked but the exec'ed program doesn't run (or at least doesn't output/input messages), as the case before.

BTW, when I did the "make menuconfig" to the original build, I selected two non-default options... arm xscale and oabi (eabi build has faulty build scripts).  I don't think these are issues, but thought I'd mention it.


On 8/2/07, Craig Hughes <craig@gumstix.com> wrote:
On Aug 1, 2007, at 7:28 PM, Peter Lu wrote:

> bootargs=console=ttyS0,115200n8 root=1f01 rootfstype=jffs2 ro 3

2 things I can think of -- the "ro" might make JFFS2 not let you
write to device nodes which are on the FS;  the "3" might not
interact with the busybox init in the way that's expected.

C

-------------------------------------------------------------------------
This SF.net email is sponsored by: Splunk Inc.
Still grepping through log files to find problems?  Stop.
Now Search log events and configuration files using AJAX and a browser.
Download your FREE copy of Splunk now >>  http://get.splunk.com/
_______________________________________________
gumstix-users mailing list
gumstix-users@lists.sourceforge.net
https://lists.sourceforge.net/lists/listinfo/gumstix-users