I'm using the default set-up for my builds, so they don't use initrd/initramfs AFAIK.  But, just for jollies I ran my rev 1482 build with rdinit=/bin/sh and the behavior is the same.  The "unable to open initial console" error happens regardless of the init'ed program.  Note that in my 1489 build, which uses the option 3 LCD display, the open succeeds but the init still hangs.

Thanks for suggestion/observation.

On 8/1/07, Brad House <brad@mainstreetsoftworks.com > wrote:

> I ran the init=/bin/sh scenario on my rev 1161, rev 1482, and rev 1489
> builds.
> The 1161 build did what was expected, ending up in sh...

If you're using an initrd/initramfs, you need to use
to drop to a shell, that changed sometime within the 2.6 kernel series.

Not sure if it's related, but just a thought...
I had modified some of the scripts on this page:
Please note the kernel options needed if using an initramfs...


This SF.net email is sponsored by: Splunk Inc.
Still grepping through log files to find problems?  Stop.
Now Search log events and configuration files using AJAX and a browser.
Download your FREE copy of Splunk now >>  http://get.splunk.com/
gumstix-users mailing list