Hello again

First of all, thanks Jean-Francois for all the help.

I started this morning trying to get the touchscreen to work but
I keep running into problems:

In regards to your steps this is what I got:

STEP 1-Creating the /dev/input/event0 in the gumstix
 I follow the instructions and I get and Error (see below)
 I think the 'pwd' is not working for me, so I tried this:
make ARCH=arm CROSS_COMPILE=/home/gumstix-buildroot/build_arm_nofpu/staging_dir/bin/arm-linux-

 This command gives me no error but when I download it to the gumstix,
 I don't even get a /dev/input.  /dev/input is missing.!!!

*** End of Linux kernel configuration.
*** Execute 'make' to build the kernel or try 'make help'.

colinux:/home/gumstix-buildroot/build_arm_nofpu/linux-2.6.15gum# make ARCH=arm CROSS_COMPILE='pwd'/../staging_dir/bin/arm-linux-

make: pwd/../staging_dir/bin/arm-linux-gcc: Command not found
  CHK     include/linux/version.h
  SPLIT   include/linux/autoconf.h -> include/config/*
  SYMLINK include/asm-arm/arch -> include/asm-arm/arch-pxa
make[1]: `include/asm-arm/mach-types.h' is up to date.
  CC      arch/arm/kernel/asm-offsets.s
/bin/sh: line 1: pwd/../staging_dir/bin/arm-linux-gcc: No such file or directory
make[1]: *** [arch/arm/kernel/asm-offsets.s] Error 1
make: *** [prepare0] Error 2

STEP 2 - building TSLIB (patching the kernel for touchscreen support)
 I downloaded the tslib.tar.gz from http://www.realfafard.com/fafard/index.php?id=31
 I unpacked it to the /home/gumtix-buildroot/build_arm_nofpu/package/tslib
 I edited Config.in in /home/gumtix-buildroot/build_arm_nofpu/package/ and I added  the 'source /package/tslib/Config.in' entry.

 then I ran 'make menuconfig' from /home/gumtix-buildroot, I went to packages and I selected tslib.
 This did not work because I did not have CVS, so I did a 'apt-get install cvs' then I tried again
 This time it downloaded the files but I get this error:

toolchain/patch-kernel.sh /home/gumstix-buildroot/build_arm_nofpu/tslib package/tslib/configure.ac.patch
Aborting.  'package/tslib/configure.ac.patch' is not a directory.
make: *** [/home/gumstix-buildroot/build_arm_nofpu/tslib/.unpacked] Error 1

STEP 3 get new ts.c
STEP 4 create new Xserver

I have not tried STEPS 3&4 becase STEPS 1&2 are not working yet.

Again, thanks for all your help

Best Regards,

PS. I do not know how to post to the initial thread, so this post will end up somewhere else