Check that you don't have /bin/sh linked to /bin/dash as is noted on this page . Having the dash link will cause it to hang at 'freeing init memory'.


On Thu, Jun 26, 2008 at 1:15 PM, XiangZ <> wrote:


I am using gumstix connex400xm. After I using OpenEmbedded bitbake to make a
new image and kernel. I used serial connection to upload  both on to the
gumstix , then it just won't reboot. It is doing something , but then
hanging before the login.

I was following procedure on the openembedded site to do the rebuild and
uploading. I have tried a few time , but it still the same.  I can use "ls "
to check the file system.

I want to know if anyone had similar problem ?

Here is the message:

U-Boot 1.2.0 (Aug 30 2007 - 13:21:47) - 400 MHz - 1513

*** Welcome to Gumstix ***

DRAM:  64 MB
Flash: 16 MB
Using default environment

Net:   SMC91C1111-0
Hit any key to stop autoboot:  0
Instruction Cache is ON
Copying kernel to 0xa2000000 from 0x00f00000 (length 0x00100000)...done
## Booting image at a2000000 ...
  Image Name:   Angstrom/2.6.21/gumstix-custom-c
  Image Type:   ARM Linux Kernel Image (uncompressed)
  Data Size:    1038444 Bytes = 1014.1 kB
  Load Address: a0008000
  Entry Point:  a0008000

Starting kernel ...

Linux version 2.6.21 (xzhou@XiangZhou) (gcc version 4.1.2) #1 PREEMPT Sat
Jun 21 22:08:52 IST 2008
CPU: XScale-PXA255 [69052d06] revision 6 (ARMv5TE), cr=0000397f
Machine: The Gumstix Platform
Memory policy: ECC disabled, Data cache writeback
Memory clock: 99.53MHz (*27)
Run Mode clock: 398.13MHz (*4)
Turbo Mode clock: 398.13MHz (*1.0, inactive)
CPU0: D VIVT undefined 5 cache
CPU0: I cache: 32768 bytes, associativity 32, 32 byte lines, 32 sets
CPU0: D cache: 32768 bytes, associativity 32, 32 byte lines, 32 sets
Built 1 zonelists.  Total pages: 16256
Kernel command line: console=ttyS0,115200n8 root=1f01 rootfstype=jffs2
PID hash table entries: 256 (order: 8, 1024 bytes)
Console: colour dummy device 80x30
Dentry cache hash table entries: 8192 (order: 3, 32768 bytes)
Inode-cache hash table entries: 4096 (order: 2, 16384 bytes)
Memory: 64MB = 64MB total
Memory: 62720KB available (1872K code, 193K data, 144K init)
Mount-cache hash table entries: 512
CPU: Testing write buffer coherency: ok
NET: Registered protocol family 16
Time: pxa_timer clocksource has been installed.
NET: Registered protocol family 2
IP route cache hash table entries: 1024 (order: 0, 4096 bytes)
TCP established hash table entries: 2048 (order: 2, 16384 bytes)
TCP bind hash table entries: 2048 (order: 1, 8192 bytes)
TCP: Hash tables configured (established 2048 bind 2048)
TCP reno registered
JFFS2 version 2.2. (NAND) (SUMMARY)  (C) 2001-2006 Red Hat, Inc.
io scheduler noop registered
io scheduler cfq registered (default)
Console: switching to colour frame buffer device 80x24
pxa2xx-uart.0: ttyS0 at MMIO 0x40100000 (irq = 15) is a FFUART
pxa2xx-uart.1: ttyS1 at MMIO 0x40200000 (irq = 14) is a BTUART
pxa2xx-uart.2: ttyS2 at MMIO 0x40700000 (irq = 13) is a STUART
pxa2xx-uart.3: ttyS3 at MMIO 0x41600000 (irq = 0) is a HWUART
Probing Gumstix Flash ROM at physical address 0x00000000 (16-bit bankwidth)
Gumstix Flash ROM: Found 1 x16 devices at 0x0 in 16-bit bank
 Intel/Sharp Extended Query Table at 0x0031
Using buffer write method
cfi_cmdset_0001: Erase suspend on write enabled
Using static partitions on Gumstix Flash ROM
Creating 3 MTD partitions on "Gumstix Flash ROM":
0x00000000-0x00040000 : "Bootloader"
0x00040000-0x00f00000 : "RootFS"
0x00f00000-0x01000000 : "Kernel"
TCP cubic registered
NET: Registered protocol family 1
NET: Registered protocol family 17
XScale DSP coprocessor detected.
VFS: Mounted root (jffs2 filesystem).
Freeing init memory: 144K

View this message in context:
Sent from the Gumstix mailing list archive at

Check out the new Marketplace.
It's the best place to buy or sell services for
just about anything Open Source.
gumstix-users mailing list